Pi 5(Bookworm OS) compatibility with Arducam camera

here is your problem:
** dmesg | grep imx **
[ 3.308953] rp1-cfe 1f00128000.csi: found subdevice /axi/pcie@120000/rp1/i2c@80000/imx477@1a
[ 3.633072] imx477 4-001a: failed to read chip id 477, with error -5
[ 3.633199] imx477: probe of 4-001a failed with error -5

in my opinion its either your cable is connected wrong, the cable is broken, the camera you have is not meant to be connected directly to raspberry pi (rather should be connected through a camera hat), the camera is broken or camera is not supported or you have wrong cable.

but ask @Dion he knows better.

also there are people in this forum that have reported same error for example Pi Zero W can't find new IR-CUT camera - #8 by Dion

he fixed it by “I grabbed a magnifying glass and stared at both the Pi Zero connector and the camera module connector and using your guidance figured out the correct connections for both. Once I did that and tried again it all just started working like it was supposed to!”

1 Like