Running B0423 - IMX462 on Pi5 bookworm

  1. Where did you get the camera module(s)?
    From Arducam (Uctronics)

  2. Model number of the product(s)?
    B0423

  3. What hardware/platform were you working on?
    Raspberry Pi 5 with Bookworm

  4. Instructions you have followed. (link/manual/etc.)
    instructions in Arducam Pi camera, specifically Ultra Low Light Starvis Camera - Arducam Wiki and the Quick start
    Quick start - Arducam Wiki

  5. Problems you were having?
    The cameras are not visible in libcamera. I have tried with different dtoverlay settings (IMX290, IMX462 and arudcam-pivariety - arducam libcamera is installed). depending on the overlayi see the cameras in dmesg, but they cannot be used by libcamera.

  6. The dmesg log from your hardware?
    see below for extracts

  7. Troubleshooting attempts you’ve made?

all possible dtoverlay combinations tested,with imx290 it appears successful, but libcamera does not see the cameras

camera_auto_detect=0
dtoverlay=arducam-pivariety,media-controller=0
dtoverlay=arducam-pivariety, media-controller=1

@rpi5-4:~ $ dmesg | grep arducam
[ 2.713043] rp1-cfe 1f00128000.csi: found subdevice /axi/pcie@120000/rp1/i2c@80000/arducam_pivariety@c
[ 3.267569] arducam-pivariety 4-000c: pivariety_read: Reading register 0x103 failed
[ 3.267581] arducam-pivariety 4-000c: probe failed

camera_auto_detect=1
dtoverlay=imx290, clock-frequency=74250000, cam0
dtoverlay=imx290, clock-frequency=74250000, cam1
@rpi5-4:~ $ dmesg | grep imx
[ 2.696849] rp1-cfe 1f00128000.csi: found subdevice /axi/pcie@120000/rp1/i2c@80000/imx290@1a
[ 3.456775] rp1-cfe 1f00128000.csi: Using sensor imx290 4-001a for capture
@rpi5-4:~ $ libcamera-still --list-cameras
No cameras available!
@rpi5-4:~ $ ls /dev/video*
/dev/video0 /dev/video2 /dev/video22 /dev/video25 /dev/video28 /dev/video30 /dev/video33 /dev/video36 /dev/video5
/dev/video1 /dev/video20 /dev/video23 /dev/video26 /dev/video29 /dev/video31 /dev/video34 /dev/video37 /dev/video6
/dev/video19 /dev/video21 /dev/video24 /dev/video27 /dev/video3 /dev/video32 /dev/video35 /dev/video4 /dev/video7

  1. What help do you need?
    how can i get the imx462 cameras visible for libcamera so i can use the cameras?
1 Like

Hi
Can you show me the output of the command “dmesg | grep imx462” when you only add “dtoverlay=imx462” on the config file?

dmesg | grep imx462 does not give output, dmesg | grep imx gives the following
@rpi5-4:~ $ dmesg | grep imx462
@rpi5-4:~ $ dmesg | grep imx
[ 3.309641] rp1-cfe 1f00128000.csi: found subdevice /axi/pcie@120000/rp1/i2c@80000/imx290@1a
[ 3.880385] rp1-cfe 1f00128000.csi: Using sensor imx290 4-001a for capture

i used the following settings
camera_auto_detect=0 (using =1 gives the same result)
dtoverlay=imx462

it is using the kernel settings
@rpi5-4:~ $ dtoverlay -l
No overlays loaded

i tried running the install_pivariety_pkgs.sh script several times, it does install libcamera, but also shows
Your camera does not need to install drivers.

1 Like

Hi
Please download the file below and try the command

libcamera-still -t 0 --tuning-file ./new_imx290.json

thanks, the camera works with this. I will do further testing as i have two imx462’s connected, but it is looking great now. Will also have to see how to use this in python, can you suggest best way forward for incorporating this into my environment?

Hi,
You can use “load_tuning_file” function.