IMX519 quad cameras - no camera available

I have issues to operate correctly IMX519 16MB Autofocus Synchronized Quad-Camera Kit.
I installed the suggested Bullseye OS version and the preferred Kernel firmware.
I think I have to follow these steps:

sudo apt-get update
sudo apt-get upgrade

and reinstall the preferred Kernel firmware (to avoid the rpi-update).

/boot/config.txt :
I think I have to delete the row
“dtoverlay=imx519”,leaving only “dtoverlay=camera-mux-4port,cam0-imx519,cam1-imx519,cam2-imx519,cam3-imx519”.
Am I correct?

Please find here the arducam bug report:

Thank you :slight_smile:



Do you have a connection diagram or sku number for the camera?

I don’t have any sku number, but I can give you my order reference:

[Order #94299] (March 7, 2023)

Is it a usefull information?

Yesterday I succeded in using the libcamera-still feature (also taking photos), but I had problems with:

  • libcamera-vid → any saved video (.h264) was not readable / the image was all black
  • autofocus → the continuous mode (or in general the autofocus mode) did not work
  • error iparpi cam_helper.cpp:243 Embedded data buffer parsing failed → this issue occurred

I do not know what to do.
Right now I’m waiting the PDAF release (as per this post IMX519 PDAF Release - #5 by Edward), but I am losing hope


Already been published, you can try again.

You can ignore this error, it has no effect on your use

try the new kernel

what commang in your use

Please refer to my reply IMX519 PDAF Release - #7 by Edward


Same as point 1

The ones reported here libcamera and libcamera-apps - Arducam Wiki

In particular I tried
libcamera-vid -t 10000 -o test.h264

Please find here arducam bugs - Google Drive the generated video “test.h264”

This is what I get when I try to record a video

  1. “/boot/config.txt”
    I left these lines
dtoverlay=imx519”,leaving only “dtoverlay=camera-mux-4port,cam0-imx519,cam1-imx519,cam2-imx519,cam3-imx519

If I delete “dtoverlay=imx519”, the command
libcamera-still --list-cameras
will give me “No cameras available”

Please find here arducam bugs - Google Drive “arducam-bug-report.txt” to have an overall description of my actual status.

Thank you.

PS: I’m using a Quad Camera B0388 Hat Array with IMX-519 modules.
PPS: My biggest problem here is point 4 → the one referred to libcamera-vid

I’m having the same problem as item #4 in this issue. My libCamera-still’s work but the libCamera-video does not work. When I try
libcamera-vid -t 10000 -o test.h264
I get a black screen with the frame number being updated. The file itself is always 1781 bytes. When I play the file back it is all black.

My /boot/config.txt is the exact same as OP. And the steps taken were very similar/the same.


libcamera-vid -t 10000 -o test.h264 --viewfinder-width 1920 --viewfiner-height 1080 --width 1920 --height 1080

This worked. Thanks so much for the prompt and effective help.

I like your products. They are very capable and at good price point. I will buy more. However, I saw a comment earlier about the documentation. I second that opinion. I had to look at multiple different instructions. Each one with an important fact. I would recommend (as did the previous poster) to remove all instructions but one. All updates should happen in this one document. I also recommend having a spec sheet that defines what versions of what are supported.


It is true that the way of use has been changing. This is because the official did not support it before, so we implemented many functions first.
Now the official has done the same function, so we have unified with the official.
We have also optimized the document update process at present, you can trust our official doc in the future.

Anyway, if you have any questions, you can ask me, I will give you the best help within the scope of my knowledge.