IMX462 raspberry PI

Hi @sseguin

There is no problem with the software settings
The hardware connections look good, except for some connectors that are not fully locked:
image

You can try to reconnect all the cables. If there is no improvement, you can replace the module through the place where you bought it.

Thank you. Keen eye. Sadly, fully closing the latch didn’t change anything.

I tried a different white ribbon cable from my other camera, and reconnected both white and brown cables, but that did not fix things either.

Is it possible to just bypass the ISP and use the sensor board directly? I’d be just as happy to have it work with an Nvidia Jetson for example, which I have here also.

Otherwise, I’ll just reach out to the supplier as you mention. Thank you for your efforts.

Unfortunately, you cannot connect the sensor directly to the Pi without using the adapter board

Now we are not compatible with Jetson, but if you install the jetvariety driver you may be able to get RAW data, but other functions will not work. (This is untested)

Just following up, but I got another IMX462 from the supplier and it worked like a charm first try. Thank you for the support.

The camera definitely has some fantastic low-light and sharp image; great for security applications. Thank you for offering it.

Thank you for your reply,
Glad your problem is solved!

Check out this SONY STARVIS IMX462 based Ultra Low Light USB camera that camera is capable of capturing high-quality images in the near-infrared region.

This USB 3.1 Gen 1 camera supports superior IR sensitivity which helps to capture high quality images in the near-infrared (~850nm) region required for night vision applications & medical microscopes. Also, the high sensitivity of this camera helps to capture images even in extremely low lighting conditions (0 lux).

Unfortunately the eCon camera is an USB UVC standard that only supports 8bit per pixel. Check ZWO and QHY for astronomy version of camera using IMX462 and can provide all 12bits per pixel… with custon driver, ( ASCOM driver )

Apparently the camera and driver only work on Pi 4. I just tried on Pi 3 B+ frez OS and driver install … it did not worked… I simply moved the SD card and camera to Pi4 and were no problems… Too bad, I have lots of Pi3 around…

Any logs?

Also you can refer to:

ok, hings start to move…
but…
I can not get long exposure, or hi grain images??? all are equally dark

please help

[email protected]:~ $ libcamera-still -o long_exposure3.jpg --shutter 50000 --gain 3 --awbgains 1,1 --immediate
Made X/EGL preview window
[0:55:13.284754363] [8439]  INFO Camera camera_manager.cpp:293 libcamera v0.0.0
[0:55:13.305862440] [8440]  WARN CameraSensorProperties camera_sensor_properties.cpp:141 No static properties available for 'arducam-pivariety'
[0:55:13.305980642] [8440]  WARN CameraSensorProperties camera_sensor_properties.cpp:143 Please consider updating the camera sensor properties database
[0:55:13.306046585] [8440] ERROR CameraSensor camera_sensor.cpp:551 'arducam-pivariety 10-000c': Camera sensor does not support test pattern modes.
[0:55:13.318147834] [8440] ERROR IPAProxy ipa_proxy.cpp:149 Configuration file 'arducam-pivariety.json' not found for IPA module 'raspberrypi'
[0:55:13.715657030] [8440]  WARN RPI raspberrypi.cpp:1233 Mismatch between Unicam and CamHelper for embedded data usage!
[0:55:13.716380442] [8440] ERROR DelayedControls delayed_controls.cpp:87 Delay request for control id 0x009a090a but control is not exposed by device /dev/v4l-subdev0
[0:55:13.716604456] [8440]  INFO RPI raspberrypi.cpp:1356 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device /dev/media0
[0:55:13.717708898] [8439]  INFO Camera camera.cpp:1028 configuring streams: (0) 1920x1080-YUV420 (1) 1920x1080-SRGGB10_CSI2P
[0:55:13.766460741] [8440]  INFO RPI raspberrypi.cpp:751 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 1920x1080-SRGGB10_1X10 - Selected unicam format: 1920x1080-pRAA
[0:55:13.808112572] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: Saturation = 1.000000
[0:55:13.808291032] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: Contrast = 1.000000
[0:55:13.808401845] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: Brightness = 0.000000
[0:55:13.808500658] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: ColourGains = [ 1.000000, 1.000000 ]
[0:55:13.808623822] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: AwbMode = 0
[0:55:13.808724857] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: Sharpness = 1.000000
[0:55:13.808824263] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: ExposureValue = 0.000000
[0:55:13.808928779] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: AeExposureMode = 0
[0:55:13.809012148] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: AnalogueGain = 3.000000
[0:55:13.809067647] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: ExposureTime = 50000
[0:55:13.809131386] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: FrameDurationLimits = [ 100, 1000000000 ]
[0:55:13.809195829] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: AeMeteringMode = 0
[0:55:13.809246995] [8445]  INFO IPARPI raspberrypi.cpp:666 Request ctrl: NoiseReductionMode = 2

another strange issue… v4l2-ctl -l returns nothing…

[email protected]:~ $ v4l2-ctl -l
[email protected]:~ $ 

This is not a problem, the new version of the kernel uses media-controller, you can use v4l2-ctl -l -d /dev/v4l-subdev0 to view the control, for more information, please refer to:
https://forums.raspberrypi.com/viewtopic.php?t=322076

I’m not quite sure what you mean, the command seems to be executed without problems.

Tested, it seems that the problem lies in the --immediate parameter, there is no problem without this parameter.

1 Like

Thank you very much Wong,

Is possible to get rid of the preview pop-up window?

Thank you

Andrei

You can add the -n parameter, but the flow doesn’t change except that there is no preview window:

  1. First open the small resolution preview (and adjust AF, AWB, AE),
  2. After reaching the specified time, switch to large resolution to take pictures.

Thank you for great information.

I was planning to use this camera for astrophotography… the sensor is known for the lowest noise level…

Unfortunately I doubt this is possible.

I was able to make the image brighter by increasing exposure time until 1s… above this value it was no improvement… there is a solution to fix this?

I tried to make the image brighter by increasing the gain, it worked up to gain of 100x but when trying 1000x it was no improvement… can this be fixed.

Least but not last, I process my image in windows… I can open pictures taken with exposure time under 1s , the ones with 1s or higher can not be opened ???

Please help. it is a pity for such a great sensor not to be able to make picture with exposure above 1s gain higher than 100x and to be opened in win…


I can not attached the bad image files, not even as zip…

How do you adjust AF, AWB and AE?

I have a preview window open but the AF, AWB and AE parts I don’t understand.

Or maybe you mean a preview in the GUI? I’m running headless.

When I start my app I get:

Made DRM preview window

[0:13:21.023280315] [877] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3416-179ef58c

[0:13:21.043450791] [878] WARN CameraSensorProperties camera_sensor_properties.cpp:141 No static properties available for ‘arducam-pivariety’

[0:13:21.043522310] [878] WARN CameraSensorProperties camera_sensor_properties.cpp:143 Please consider updating the camera sensor properties database

[0:13:21.043592569] [878] ERROR CameraSensor camera_sensor.cpp:551 ‘arducam-pivariety 10-000c’: Camera sensor does not support test pattern modes.

[0:13:21.052621144] [878] ERROR IPAProxy ipa_proxy.cpp:149 Configuration file ‘arducam-pivariety.json’ not found for IPA module ‘raspberrypi’

[0:13:21.408305635] [878] WARN RPI raspberrypi.cpp:1233 Mismatch between Unicam and CamHelper for embedded data usage!

[0:13:21.408954392] [878] ERROR DelayedControls delayed_controls.cpp:87 Delay request for control id 0x009a090a but control is not exposed by device /dev/v4l-subdev0

[0:13:21.409189131] [878] INFO RPI raspberrypi.cpp:1356 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media0 and ISP device /dev/media2

[0:13:21.409859184] [877] INFO Camera camera.cpp:1028 configuring streams: (0) 960x640-YUV420

[0:13:21.439368030] [878] INFO RPI raspberrypi.cpp:751 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 1920x1080-SRGGB10_1X10 - Selected unicam format: 1920x1080-pRAA

[0:13:21.476544323] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: Saturation = 1.000000

[0:13:21.476641434] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: Contrast = 1.000000

[0:13:21.476668526] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: Brightness = 0.000000

[0:13:21.476692674] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: AwbMode = 0

[0:13:21.476718656] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: Sharpness = 1.000000

[0:13:21.476742600] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: ExposureValue = 0.000000

[0:13:21.476786211] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: AeExposureMode = 0

[0:13:21.476844174] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: FrameDurationLimits = [ 33333, 33333 ]

[0:13:21.476921395] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: AeMeteringMode = 0

[0:13:21.476956247] [885] INFO IPARPI raspberrypi.cpp:666 Request ctrl: NoiseReductionMode = 1