ESP32S UNO PSRAM not creating hotspot

I have just purchased two ESP32S UNO PSRAM boards with the goal of creating remote battery operated web cameras. I am attempting to follow the initial configuration of the cards to use the face detection demo, but no hotspot is created when I plug my board into my PC via USB.

My board model is Arducam UC-617 Rev. A


Any help would be appreciated.


Please open the serial monitor to see the debug message. No hotspot, most of the time it’s because the camera isn’t properly initialized


This is a bug caused by twice initializations of the serial port. We have fixed it. You can find it in Tools->Board:“Arducam ESP32S UNO PSRAM” ->Boards Manager to reinstall Arducam ESP32S Boards . The new version is 1.0.1.


I am unable to install version 1.0.1.

I am attempting to follow the instructions on the Git source page. I am referencing this page:

I have added the following URL from the Git page into the Properties|Additional Boards Manager URLs:

When I attempt to select the board via the Board Manager I am only finding version 1.0.0.

I am using the Windows 10 install of Arduino v 1.8.12 (Windows Store

bin - Here is the message in the Serial Monitor: ⸮⸮⸮N1⸮!⸮⸮


The baud rate seems error. Please ensure the baud rate firstly and it is 115200 .

Let me know if you need more help.


Please uninstall the vision 1.0.0 Arducam ESP32S Boards in Board Manager ,and reinstall the vision 1.0.1.

The problem has been solved in latest vision.If you do not want to update the board library, you can comment out the line 63 ‘Serial.begin(115200);’ in the face detection demo.

I understand that I need to update the version to 1.0.1 - I do not know WHERE to get the version. The link leads to version 1.0.0, not 1.0.1.

The JSON file above refers to version 1.0.0. Where can I find the new version?

The other issue is that the hotspot does not appear when I plug in the camera. The documentation says that all I need to do is plug in the board and it should create a hotspot. It does not say that I even need to have the Arduino IDE installed. Why is the hotspot not being created?


Please use this link for now, and we will update the file to the link specified in the user guide later.

I attempted to add this comment before, but I did not see it appear in the thread. I am writing it again in case there was an error or it was too long.

Thank you for your help so far. I found that I needed a SIM card in the board in order for the hotspot to function.

I am still unable to load the facial recognition test from the Arduino IDE. I get the following error:

Sketch uses 2255510 bytes (71%) of program storage space. Maximum is 3145728 bytes.
Global variables use 51728 bytes (15%) of dynamic memory, leaving 275952 bytes for local variables. Maximum is 327680 bytes. v2.6
Serial port COM4

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header
A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

I have installer version 1.0.1, and I have attempted loading the code both with and without the code Serial.begin(115200);

Any help would be appreciated.


Please connect the GPIO0 to GND to make the ESP32 in downloading mode.


Please connect the GPIO0 to GND to make the ESP32 in downloading mode.


my serial moniter showing this … Camera init Success but ip address for streaming not showing… how can i solve it…

It looks like your board is continuously resetting. I don’t know which sketch you are using but I’m willing to bet it’s resetting at the point of initializing the WiFi. This would suggest the board is not receiving enough power. How are you powering the board? Is there any other connections to the board? if there is, remove them. Try just the WiFi example sketch where it lists all the local SSID’s and RSSI’s.


What @Valdhor said is a possible cause. Can you describe your problem more specifically? Which demo did you use? Is the serial port continuously output reset manually or automatically?

@Valdhor i am using face detection sketch… same issue remain after attaching external power supply by connecting battery… i used lipo 3.7v, 2000mah, 5C

@Valdhor How can i record video with Arducam ESP32S UNO PSRAM without connecting to wifi… It should record video offline and transfer to to SD card…Can any one send link for code or project that related to my topic… thanks

Before experimenting with the battery I would just try a quality USB cable directly from a USB port on your computer. ie. Not from a USB Hub or anything like that. Make sure you have no other USB devices connected (Some PC’s have a built-in USB Hub which could be taking power away from your board). Remove and re-install the drivers. Make sure you have the latest “Arducam ESP32S Board” in board manager (You may just want to delete the whole Arduino install and start from scratch. I have had to do this a few times as I have many Arduino boards. You may also want to look into PlatformIO as an alternative to Arduino IDE). Then select the WiFi example from that board examples. It should just show the closest SSID’s with the associated RSSI on the serial port. Once you get that working then try the big example connecting the camera.


Now, when you say you connected the LiPo battery, did you cut off the connector and solder on the cable provided with the ESP32S UNO PSRAM? The battery connector on the board is backwards. If you just connected the battery without doing this you can easily fry the board.

@Valdhor can you tell me how can i connect the 9V external battery to UNO PSRAM … if you have any sketch or pic then please share…