64MP QuadCamera - No cameras available!

I’m getting the same errors in dmesg as before.

Here is the wiring



@vulturev1

Just to confirm your current status, can you provide this information again?

uname -a
dmesg | grep arducam

@Edward

raspberrypi@raspberrypi:~ $ uname -a
Linux raspberrypi 5.15.84-v7l+ #1613 SMP Thu Jan 5 12:01:26 GMT 2023 armv7l GNU/Linux

and

[   10.078172] arducam_64mp: loading out-of-tree module taints kernel.
[   10.088987] arducam_64mp 10-001a: failed to read chip id 4136, with error -5
[   10.089821] arducam_64mp: probe of 10-001a failed with error -5

@Edward

I also note this seems very similar to

In which you had responded. Did the problem for the user linked above get solved? What was the issue?

@vulturev1

In this case it is possible that the flex cable is the problem and the camera is not being recognized.

0x0c is the address of the motor, the motor loads correctly, but the camera doesn’t read the i2c address, which is weird.

I would like to please make another try:
Unplug the flex cable all over and reinstall it once.

Please send a clearer picture of the following, I want to see the circuit.
image

Where are you seeing the 0x0c motor address? But yeah I’ve tried removing the cable and putting it back from both the sockets to no avail.

I hope this image is clear enough

@vulturev1

I saw in another thread that you have more detailed information.

0x0c is mentioned in it

When I zoom in on the picture you gave, I can’t see the details.

I’m sorry that was a terrible image

I hope this one is better

@Edward

@Edward

Here is one with the PCB traces visible

@vulturev1

tx, very clearly

@vulturev1

I discussed it with my team just now, and it’s really weird.
Now there are three possibilities:

  1. The interface of the Raspberry Pi camera is broken (less likely), to rule this out is to find out whether another mipi camera can work (it does not matter, we can default to good)
  2. The camera module is broken (in this case, we can return or exchange the product for a try)
  3. The flexible cable is broken (if you have another flexible cable, you can try another one, if you don’t have one, forget it)

If you can’t get the test I’m appealing, you can try an exchange or return it

I’ll try these tests, I’ll head out now and get a cheapo camera and spare wire

@vulturev1

Thank you for your efforts.

Hi. I am getting the no cameras available issue. I am using arducam 64mp camera on Raspberry Pi 3 Model B.

Can someone help me figure this out. I tried following the solutions above but they are not working.