108MP camera size exceed error for C++ (update USBTest source code required

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?
    108MP usb 3

  3. What hardware/platform were you working on?
    Windows 10 and 11 on 64bit Intel and AMD

  4. Instructions you have followed. (link/manual/etc.)
    ArduCAM_USB_Camera_Shield/Windows/GUI/USBTest/x64/Release at master · ArduCAM/ArduCAM_USB_Camera_Shield · GitHub

ArduCAM_108MP - USB camery buffer create error - Arducam Camera Support Forum

  1. Problems you were having?
    I am integrating the camera to my c++ platform software. The 4000x3000 cfg in the github is working well, using the code example in USBTest. However, when running the 12000x9000 cfg, I get the camera size exceed error during ArduCam_open(). The USBTest x64/release version in github work ok on my machine with the 12000x9000, so does the upper software in other forum threads.

I linked the ArduCamLib.dll in the USBTest x64/release for my code in hopes that it will work, but it didn’t. Because the USBTest source code is 2 years old, while the x64/release is 1 year old, is there an updated USBTest source code, that allows the newer binaries to work for full 108MP? can we get access to that code to help with this integration, or what additional functions or settings are required before open.

  1. The dmesg log from your hardware?

  2. Troubleshooting attempts you’ve made?
    The newer USBTest binaries are working well on my x86 windows machine, so the hardware does not have issues. I tried using the updated dll to link, but still have the error. The main issue I can see is that I am using the older version of USBTest and streaming examples for c++ integration. I suspect there are additional steps before calling open() to get full 108MP resolution.

  3. What help do you need?
    What additional steps at c++ source code level to get 108MP at full resolution.

You can refer to the sample in the link below:

Thanks, the libraries from this link worked. Got 108MP streaming