What Camera Module am I actually using

  1. Where did you get the camera module(s)?
    ArduCam

  2. Model number of the product(s)?
    No Idea

  3. What hardware/platform were you working on?
    Raspberry Pi 4
    OS: Raspbian GNU/Linux 11 (bullseye) aarch64

  4. Instructions you have followed. (link/manual/etc.)
    Quick Start - Arducam Wiki

  5. Problems you were having?
    root@lager:/home/driver# libcamera-still
    Preview window unavailable
    [0:02:11.883945943] [1650] INFO Camera camera_manager.cpp:297 libcamera v0.0.0+4367-ad9428b4
    ERROR: *** no cameras available ***
    root@lager:/home/driver# vcgencmd get_camera
    supported=1 detected=0, libcamera interfaces=1
    root@lager:/home/driver# i2cdetect -y 10
    0 1 2 3 4 5 6 7 8 9 a b c d e f
    00: – – – – UU – – –
    10: – – – – – – – – – – – – – – – –
    20: – – – – – – – – – – – – – – – –
    30: – – – – – – – – – – – – – – – –
    40: – – – – – – – – – – – – – – – –
    50: – – – – – – – – – – – – – – – –
    60: – – – – – – – – – – – – 6c – – –
    70: – – – – – – – –

  6. The dmesg log from your hardware?
    root@lager:/home/driver# dmesg | grep imx
    [ 9.138221] imx519 10-001a: failed to read chip id 519, with error -5
    [ 9.139410] imx519: probe of 10-001a failed with error -5

  7. Troubleshooting attempts you’ve made?
    Follow multiple guides.

  8. What help do you need?
    I’m do not really know what this camara is expect that the camera module has “UC-721 Rev.D” written on the PCB. Thanks for the help in advance.

The Image above shows my current configuration and the camera itself.

Here are some more guides that I took in order do make it function myself but it did not work:

https://docs.arducam.com/Raspberry-Pi-Camera/Motorized-Focus-Camera/Quick-Start-Guide/OV5647-Motorized-Focus-Camera/