Wavy out of focus lines in photos from distance

  1. Where did you get the camera module(s)? Arducam

  2. Model number of the product(s)? 16mp imx519

  3. What hardware/platform were you working on? Raspberry pi 4b

  4. Instructions you have followed. (link/manual/etc.) Quick Start - Arducam Wiki

  5. Problems you were having?
    When taking photos above 5-10m I get some shots which have wavy blurrly lines, otherwise the photos would be perfect. Its taken with a drone. Both when moving and when not moving

  6. The dmesg log from your hardware?

  7. Troubleshooting attempts you’ve made? Tried different libcamera-still settings but can’t change it. Sett Exposure to 1us

  8. What help do you need?

Advice on what causes it, and troubleshooting tips. I have googled everywhere and nobody else seems to have the problem.

Example image with issue (most obvious is the trees near top middle): capture-0091 hosted at ImgBB — ImgBB

Hi @tank104
After checking the image you attached, I would like to know if this picture was captured when the drone was moving or not moving. If the drone was moving, can you attach another image which is captured when the drone is not moving?
Imx519 is using rolling shutter which could cause Roller effect and can not focus very well when moving.

Hi Dion,
Thanks for responding. We have tried it both when hovering, and when moving. When hovering though the drone does still slightly move as expected with a drone. However both times still get the effect. Its not always though - sometimes moving and hovering the capture is great.

Is there a better camera you can recommend for my use case though? i.e. taking aerial shots between 60-100m whilst still and moving?

Hi @Dion ,
Just wondered if you had any update on this thanks.

Hi,
I can recommend the global shutter camera below:

Thanks! Sorry for late reply I didn’t get any email that was responded.

Is there any larger MP camera version ?

HAd a search and that does look like highest resolution - thanks