V3Link kit: no cameras available

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?
    SKU: B0491
    Kit composed by:

  • IMX219 camera assembled with V3Link Camera Interface Board,
  • V3Link Adapter Board for Raspberry
  • screws, PCB spacers, flat cables
  1. What hardware/platform were you working on?
    Raspberry Pi4 Model B
    Fresh new Raspberry Pi OS 64-bit (Debian Bookworm) created by Raspberry PI Imager. Suddenly after the first login, I issued apt-get update and apt-get full-upgrade.

  2. Instructions you have followed. (link/manual/etc.)
    Standard instruction from Arducam and Raspberry web sites.

  3. Problems you were having?
    All the tools that manages camera isn’t able to detect the camera. For example:

pi@raspberrypi:~ $ libcamera-hello
[1:34:55.981139490] [33584]  INFO Camera camera_manager.cpp:284 libcamera v0.2.0+46-075b54d5
Preview window unavailable
ERROR: *** no cameras available ***

This is another command (I don’t know it it’s relevant):

pi@raspberrypi:~ $ vcgencmd get_camera
supported=0 detected=0, libcamera interfaces=0
  1. The dmesg log from your hardware?
    Forum said I can’t write long posts, so I shared the log here dmesg

  2. Troubleshooting attempts you’ve made?
    I tried to bypass V3Link, connecting the Pi4 board directly to the camera PCB (after disconnecting its camera adapter board). No success.

  1. What help do you need?
    I suspect there’s a problem with the software.

First question: is the camera module I received in the kit exactly the same as the simple IMX219 (SKU B0393 or B0390) camera module with MIPI interface?

How Raspberry can detect the camera?

I changed /boot/firmware/config.txt adding:

camera_auto_detect=0 # commenting camera_auto_detect=1
dtoverlay=imx219 # at the end of the file

and rebooted. Now, when the camera is connected directly to Pi4 (bypassing V3Link), libcamera-still works and an image file is generated. So why do I need to add dtoverlay and doesn’t autodetect work as expected?

Anyway I tried to restore V3Link, but now I receive the following errors:

pi@raspberrypi:~ $ libcamera-still -n -o test.jpg
[0:23:58.295670450] [2014]  INFO Camera camera_manager.cpp:284 libcamera v0.2.0+46-075b54d5
[0:23:58.342669255] [2017]  WARN RPiSdn sdn.cpp:39 Using legacy SDN tuning - please consider moving SDN inside rpi.denoise
[0:23:58.344670551] [2017]  WARN RPI vc4.cpp:393 Mismatch between Unicam and CamHelper for embedded data usage!
[0:23:58.345447315] [2017]  INFO RPI vc4.cpp:447 Registered camera /base/soc/i2c0mux/i2c@1/imx219@10 to Unicam device /dev/media1 and ISP device /dev/media0
[0:23:58.345522851] [2017]  INFO RPI pipeline_base.cpp:1144 Using configuration file '/usr/share/libcamera/pipeline/rpi/vc4/rpi_apps.yaml'
Mode selection for 1640:1232:12:P
    SRGGB10_CSI2P,640x480/0 - Score: 4504.81
    SRGGB10_CSI2P,1640x1232/0 - Score: 1000
    SRGGB10_CSI2P,1920x1080/0 - Score: 1541.48
    SRGGB10_CSI2P,3280x2464/0 - Score: 1718
    SRGGB8,640x480/0 - Score: 5504.81
    SRGGB8,1640x1232/0 - Score: 2000
    SRGGB8,1920x1080/0 - Score: 2541.48
    SRGGB8,3280x2464/0 - Score: 2718
Stream configuration adjusted
[0:23:58.347181116] [2014]  INFO Camera camera.cpp:1183 configuring streams: (0) 1640x1232-YUV420 (1) 1640x1232-SBGGR10_CSI2P
[0:23:58.347582572] [2017]  INFO RPI vc4.cpp:611 Sensor: /base/soc/i2c0mux/i2c@1/imx219@10 - Selected sensor format: 1640x1232-SBGGR10_1X10 - Selected unicam format: 1640x1232-pBAA
[0:23:59.553375059] [2017]  WARN V4L2 v4l2_videodevice.cpp:2007 /dev/video0[13:cap]: Dequeue timer of 1000000.00us has expired!
[0:23:59.553477927] [2017] ERROR RPI pipeline_base.cpp:1376 Camera frontend has timed out!
[0:23:59.553510778] [2017] ERROR RPI pipeline_base.cpp:1377 Please check that your camera sensor connector is attached securely.
[0:23:59.553543815] [2017] ERROR RPI pipeline_base.cpp:1378 Alternatively, try another cable and/or sensor.
ERROR: Device timeout detected, attempting a restart!!!

What the hell now?

Hi Giuseppe,
Let’s talk here. If any progress to this problem, I hope this thread will help other customers who face the same problem with you :slight_smile:

It should be B0390 other than B0393.

IMX219 camera sensor needs to confirm encryption when connected to the Raspberry Pi board. Hence, the third-party camera boards work as expected after we add the entry dtoverlay=imx219.

Power your Raspberry Pi off, assemble the v3 link as shown in the following figure, and then power your Raspberry Pi. This is the standard operation.

Please retry the libcamera command to see if the problem is solved when your pi is starting.

1 Like

Let’s talk here. If any process to this problem, I hope this thread will help other customers who face the same problem with you :slight_smile:


It should be B0390 other than B0393.


Ok, I would suggest to specify the changes in config.txt somewhere in your docs, for example here. I found just a paragraph in a doc from Raspberry, but it says:

Yeah, it seems working now. I don’t explain why, maybe I was using the other coax channel, marked as RX1 on V3Link adapter board.

Hi @giusloq
One tips, please make sure that you have assembled the v3 link as shown in the aboving figure before you prepare to power your Raspberry Pi. IF you assemble the v3 link in a hot-line work, your Pi will refuse to recognise the imx219 camera module.

Sure, I always assembled, disconnected and reconnected cable (coaxial cable and flat cables) when the power is off. Anyway, thanks for the hint.

1 Like