Using Stereo camera with Xavier NX and ROS 2 Humble

  1. Where did you get the camera ?
    Arducam 1MP Stereo Camera for Raspberry Pi, Nvidia Jetson Nano and Xavier NX, Dual OV9281 Monochrome Global Shutter Camera Module

  2. Model number of the product(s)?

  3. What hardware/platform were you working on?
    Jetson Xavier NX latest Jetpack and ROS 2 Humble

  4. Instructions you have followed.

There are no instructuons for ROS 2

  1. Problems you were having?

No instructions for latest Jetpack and ROS 2

  1. What help do you need?

Please provide instructions on how to use the mentioned product with Xavier NX latest Jetpack and ROS 2 Humble.



Sorry. We have not tested this project on the latest version of ROS2.

However, we will no longer be updating this project.

You can continue to use the old version of ROS mentioned in the tutorial for testing purposes.

Thanks @Edward for your response.
This is actually very unfortunate. I only bought this camera becuase in the instructions video you had showed the logo of ROS 2 which I assumed is supported. I am not uing ROS 1 anymore, so this is not useful for me.

However, if you can point me on how to use this camera outside ROS, I would be happy to create the requored ROS 2 node for it.

I am usin Xavier NX with Jetpack R35.1.0. How can I run your driver on it?


Maybe @lvbin can help somehow ?


You can use the camera with this example:

Thanks @Edward . I will try and let you know.

I noticed that the instructions mentioned to install v4lt-fix if using Python3.x. Is this still needed with latest Jetson Jetpacks? Or the regularl v4lt is fine?


To the best of my knowledge, v4l2-fix is considered to be the more stable option.

Thanks @Edward I am able to use the stereo camera with Xavier NX R35.1.0 Jetpack. I also used v4l2-fix

  1. My issue now is that the frames are very bright. Is there a way to reduce the exposure time, or how to fix this issue?

2 . Another question is, when I run python3 --fps, I get 50fps. Is it possible to get higher FPS with other resolution?

Thank you very much for your help.


You can try lowering the resolution

You can adjust exposure with v4l2-ctl

View all supported controls

v4l2-ctl -l


v4l2-ctl -c [control_name]=[number]


v4l2-ctl -c exposure=1000

Thanks @Edward !

I implemented ROS 2 package that worked with me using the dual OV9218 on Jetson Xavier NX.

Hopefully, it is useful for the community.

1 Like

Hi @Edward

I tried your suggestion to set the exposure using the command

v4l2-ctl -c exposure=1000

However, there is no change in the exposure.
I guess I need to use software in my ros2 node to set the exposure time. Is that right?

Can I use the here module to do that? If that is the case, how to do that?

Thanks for your assistance.


Are you writing this value when the camera is turned on?