Unable to get IMX519 recognized

Hi all,
I have a raspberry pi zero W fresh out of the box with an IMX517 camera. I am unable to get the pi to recognize the camera at all. The OS is the current Raspberry pi OS lite 32 bit (still Bullseye 6.1.21) that comes when using the raspberry pi imager. Im also following the quickstart guide:
The pi itself is working fine, I have no issues with connecting to my wifi and SSH’ing into it. Ive quadrupled check’d the orientation for the camera ribbon (UC-376) on both ends.

No matter what I do I get “No cameras available”. Ive manually installed the libcamera libraries just to check, although it was my understanding that they come preinstalled with this version of bullseye. I’ve re-imaged my pi as well. This is rather early in the process to be having issues, so I was hoping someone may be able to help me troubleshoot this. Im not sure what else to put that may help, but if requested I will post the dmesg.

Thank you for any help!

Hi @somethingClever
Welcome to our community!
For further debugging, I need the information listed below:

  • Pictures of hardware connection–both Raspberry Pi’s end and camera’s end. Because you are new to the forum, you may be limited to post one picture in one reply.

  • The output of the command cat /boot/config.txt

  • The output of the command dpkg -l | grep libcamera

Hi Dion, thanks for reaching out. I apologize for taking so long to respond.

Here is the output of dpkg -l | grep libcamera

Here is the config:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable infrared communication.

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Automatically load overlays for detected cameras

# Automatically load overlays for detected DSI displays

# Enable DRM VC4 V3D driver

# Disable compensation for displays with overscan

# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.


# Run as fast as firmware / board allows


Ill post pictures of the connectors when I have physical access to the pi again. However, I will say I do not remember editing the config file, so if that is a necessary step, that might be my issue.
Thank you again for the help, I will post the connections soon.

The connecter to the pi:

The camera side connection:

Im just realizing the config file is the part I missed. Definitely was in the documentation. I apologize for using up your time.

1 Like