Unable to connect Arducam IMX219 on RPI Bullseye

Hi,

I recently installed a fresh image of 32 bit Bullseye image on my RPI 4 Model B. I bought an IMX219 camera that I wish to install.

In my boot config file, I set camera_auto_detect=0 and set the dt_overlay=imx219.

When I run libcamera-hello, i get the error:
Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 1640x1232-SBGGR10_1X10 - Selected unicam format: 1640x1232-pBAA

It says the the Uncam has timed out, please check your camera sensor connector is attached securely.

I have tried this with a different camera and a different ribbon cable and the issue persists. I have ensured that the ribbon cables are attached correctly.

Can you please advise what I should do to get the Arducam IMX219 camera working with my RPI running the Bullseye OS. Thank you.

Hi,
Have you tried dtoverlay=imx219 without _?

Yes, that did not resolve the issue. Do you have any other recommendations on what I can try to fix it?