Still image capture with Camarray Quad HAT on RPI4

1.Which seller did you purchase the product(s) from? Uctronics,

2.The Model number of the product(s) you have purchased? Camarray – Arducam 1MP Quadrascopic Camera Bundle Kit

3.Which Platform are you using the product(s) on? RPI4

4.Which instruction are you following? instructions from here -

5.Has your product ever worked properly? I have everything working according to the instructions.

6.What problems are you experiencing? I want to capture still images and save to a file. What is the best process for this currently?

7.What attempts at troubleshooting have you already made? Google for answers. Qcam is a potential solution? Raspistill

8.How would you like us to help you? Suggestions please. Thanks!

I was able to capture using arducamstill commands but only in GREY 8-bit Greyscale.

v4l2-ctl --list-formats-ext
I am only seeing the format [0] : 'GREY' (8-bit Greyscale) ? No Y10P or Y10 shows when I run the command. I have checked the ribbon cables. What am I overlooking?


  1. Make sure if your driver installed successfully;

  2. Please send us the error to help us troubleshooting(for your trouble, we checked our doc without problems).