RPi 5 and OwlSight 64 MP Camera

  1. Where did you get the camera module(s)?
    ArduCam

  2. Model number of the product(s)?
    B0483

  3. What hardware/platform were you working on?
    Raspberry Pi 5 4GB

  4. Instructions you have followed. (link/manual/etc.)
    64MP OwlSight - Arducam Wiki

  5. Problems you were having?
    Camera not detected. In camera 0 port.

  6. The dmesg log from your hardware?
    N/A

  7. Troubleshooting attempts you’ve made?
    Checked cable
    Changed /boot/firmware/config.txt
    Fresh install

  8. What help do you need?

  9. How do I get the camera to run?

  10. Can I use two 64 MP cameras?

The output when running libcamera-hello is below:

[0:04:54.210415013] [1025]  INFO Camera camera_manager.cpp:284 libcamera v0.1.0+147-057299d0-dirty (2024-01-24T08:51:15+00:00)
Options:
    verbose: 2
    info_text:#%frame (%fps fps) exp %exp ag %ag dg %dg
    timeout: 5000ms
    width: 0
    height: 0
    output:
    post_process_file:
    preview: default
    qt-preview: 0
    transform: identity
    roi: all
    metering: centre
    exposure: normal
    ev: 0
    awb: auto
    flush: false
    wrap: 0
    brightness: 0
    contrast: 1
    saturation: 1
    sharpness: 1
    framerate: 30
    denoise: auto
    viewfinder-width: 0
    viewfinder-height: 0
    tuning-file: (libcamera)
    lores-width: 0
    lores-height: 0
    autofocus-range: normal
    autofocus-speed: normal
    autofocus-window: all
    hdr: off
    mode: unspecified
    viewfinder-mode: unspecified
    metadata:
    metadata-format: json
    keypress: 0
    signal: 0
No connector ID specified.  Choosing default from list:
Connector 32 (crtc 88): type 11, 3840x2160 (chosen)
Connector 42 (crtc 0): type 11, 0x0
Made DRM preview window
Opening camera...
Closing RPiCam application(frames displayed 0, dropped 0)
Camera stopped!
Tearing down requests, buffers and configuration
Camera closed
ERROR: *** no cameras available ***

It appears the software is not fully ready yet.

The ‘upstream support’ is still pending on the RPi end. So, yeah. I guess I am stuck for now.

Hi,
Currently, the Raspberry Pi has released kernel version 6.1.73 , which already includes the built-in support for the OV64A40 camera module. Therefore, there is no need for separate driver installation and libcamera.
We have update our doc, please check it:
https://docs.arducam.com/Raspberry-Pi-Camera/Native-camera/64MP-OV64A40/#software

Hi Dion,

With all respect - that just is not true right now.

The Pull Request is still open and yet to be merged.

Until it is merged, your statement that it has built-in support is not true.

I managed to get the camera to work by using the ArduCam version of libcamera. The default Raspberry Pi libcamera (raspi-cam or whatever they call it) does not support the OV64A40.

The upstream libcamera library (0.2.0) does support the OV64A40 camera, but that is not supported by Raspberry Pi 5 yet.

You may need to put some pressure on Raspberry Pi foundation / company / code maintainers to get the software support ArduCam deserves.

Hi,
Got it. Thank you for your feedback:-)
I’ll verify the current situation.

1 Like

Thank you for following up Dion.

Can I also say that it is not upstreamed for Raspberry Pi 4 either. I tried both devices and the camera does not work ‘out of the box’ for either.

I have left this message on the Pull Request as a comment so that hopefully someone can speed up the process of getting the code working.

The Pull Request has been idle since November 2023 (nearly 6 months). I do not believe this is a problem with the ArduCam team, but with the Raspberry Pi maintainers. I am here to help get this moving along (and have been trying).

Hi,
Thank you for your effort.
Besides, I tried the Raspberry Pi native libcamera to run the OV64A40 and it worked. Please see the screenshots below:




I was running it on Raspberry Pi 5.

Hi Dion,

I will try and test again with a blank SD Card later tonight. It appears something has changed since I posted on the forum here. Your release is dated 15 Feb 2024 which is after I created this question.

Let me get back to you.

Hi

Yes.

Beside, the PR below is no longer useful because the ov64a40 has been merged into the upstream mainline.

Raspberry Pi will pull the upstream mainline code directly.Here you can see the ov64a40 code, already in the Raspberry PI’s libcamera repository.

1 Like

Any word if this is going to apply to the RPi4 too? I’ve been trying to get it work unsuccessfully.