Raspberry PI Zero 2 W and IMX519 / 16MP Autofocus: 64MB GPU memory needed?

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?

  3. What hardware/platform were you working on?
    Raspberry Pi Zero 2 W

  4. Instructions you have followed. (link/manual/etc.)

  5. Problems you were having?
    Message: No camera found.

  6. The dmesg log from your hardware?

  7. Troubleshooting attempts you’ve made?

We are using it without a screen connected. libcamera-still with -n option (and others for sure).
libcamera-still --list-cameras says “no cameras”.

We detected the the amount of GPU memory has an influence.
Default 64MB on a Zero 2 W (which has only 512MB).
Therefore we reduced to 16MB (which is the minimum) with raspi-config.
But then the cameras are not detected anymore.

Setting GPU memory back to 64MB and everything is fine again.
But 48MB are almost 10 percent of the available.

  1. What help do you need?
    Why libcamera-still is depending on GPU memory even in head-less mode with option “-n”?

Thank you very much!


I’m sorry, I haven’t experienced this situation before, and my knowledge of the GPU part of the Raspberry Pi is limited. You may want to try asking about the GPU settings and their potential impact on camera detection on the official Raspberry Pi forum.

Thank you for your reply.
32MB or more GPU RAM and ist is fine.
16MB is too less. Then no cameras are detected.

For me it’s fine, now.

Intention for my post was to give others the hint, that the amount of GPU memory may have an influence to functionality.

1 Like