Raspberry pi 5 compatibility with multicamera adapter?

Is the v2.2 4 camera multiplexer compatible with raspberry pi 5? I have followed the instructions on the website (editing the boot config) and I keep getting a no cameras available error when running libcamera-hello.

1 Like

Hi
Please post the output of the commands below:

cat /boot/config.txt
libcamera-still --list

Besides, it would be appreciated if you can send us pictures of hardware connection.

1 Like

For more options and information see

Raspberry Pi Documentation - The config.txt file

Some settings may impact device functionality. See link above for details

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Enable audio (loads snd_bcm2835)

dtparam=audio=on

Additional overlays and parameters are documented

/boot/firmware/overlays/README

Automatically load overlays for detected cameras

dtoverlay=camera-mux-4port,cam0-imx708,cam1-imx708,cam2-imx708,cam3-imx708
camera_auto_detect=0

Automatically load overlays for detected DSI displays

display_auto_detect=1

Automatically load initramfs files, if found

auto_initramfs=1

Enable DRM VC4 V3D driver

dtoverlay=vc4-kms-v3d
max_framebuffers=2

Don’t have the firmware create an initial video= setting in cmdline.txt.

Use the kernel’s default instead.

disable_fw_kms_setup=1

Run in 64-bit mode

arm_64bit=1

Disable compensation for displays with overscan

disable_overscan=1

Run as fast as firmware / board allows

arm_boost=1

[cm4]

Enable host mode on the 2711 built-in XHCI USB controller.

This line should be removed if the legacy DWC2 controller is required

(e.g. for USB device mode) or if USB support is not required.

otg_mode=1

[all]

1 Like

libcamera-still --list outputs “no cameras available”


what do yo want an image of?

1 Like

Hey any updates on this?

Hello! I am also having issues connecting a quad hat imx708 to a raspberry pi 5.
Here’s what I did: I modified the config.txt as noted in the quick install:
camera_auto_detect=0
dtoverlay=imx708
#Save and reboot.

then, I ran
libcamera-still --list
got no cameras detected.

then, I looked in the forums and noted that someone said to change the config.txt overlay to this:
dtoverlay=camera-mux-4port,cam0-imx708,cam1-imx708,cam2-imx708,cam3-imx708
camera_auto_detect=0
#save and reboot
So I tried that, and still
libcamera-still --list
no cameras found!

I am at a loss here… any more help available? Thanks!

My guess is that there is an issue with the config.txt, so here it is in the entirety
"# For more options and information see

Raspberry Pi Documentation - The config.txt file

Some settings may impact device functionality. See link above for details

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Enable audio (loads snd_bcm2835)

dtparam=audio=on

Additional overlays and parameters are documented

/boot/firmware/overlays/README

Automatically load overlays for detected cameras

camera_auto_detect=0
dtoverlay=imx708

Automatically load overlays for detected DSI displays

display_auto_detect=1

Automatically load initramfs files, if found

auto_initramfs=1

Enable DRM VC4 V3D driver

dtoverlay=vc4-kms-v3d

max_framebuffers=2

Don’t have the firmware create an initial video= setting in cmdline.txt.

Use the kernel’s default instead.

disable_fw_kms_setup=1

Run in 64-bit mode

arm_64bit=1

Disable compensation for displays with overscan

disable_overscan=1

Run as fast as firmware / board allows

arm_boost=1

[cm4]

Enable host mode on the 2711 built-in XHCI USB controller.

This line should be removed if the legacy DWC2 controller is required

(e.g. for USB device mode) or if USB support is not required.

otg_mode=1

[all]

dtparam=uart0=on
"

Hi,
This enabling driver way is correct. Kindly note that there are two csi ports on the Raspberry Pi 5, and dtoverlay=imx708 is enabling the CAM 1 port and dtoverlay=imx708,cam0 is enabling the CAM 0 port.
Which csi interface do you connect to the HAT board>?

Hi,
Please connect CAM 1 port instead of CAM 0 port to the multi camera adapter.

1 Like

Thank you, camera is working !!

We had the camera hooked to the wrong port. All good now, thanks!