Python3 is unstable

1.Which seller did you purchase the product(s) from?
Other Arducam Distributor (Tokopedia)
2.The Model number of the product(s) you have purchased?
IMX219 8MP For Raspberry Pi
3.Which Platform are you using the product(s) on?
Raspberry Pi 4B
4.Which instruction are you following?
5.Has your product ever worked properly?
work intermittently
6.What problems are you experiencing?
Excuse me, i’m having another problem for my camera module, when i’m tried on raspistill command the image is clear and no error, when i tried Python3 the image RGB is all green, and i can’t calibrate the chessboard because the green image error, is that because of the camera or the program ? thank you
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?
show the solutions troubleshooting properly

Hi @AldifaJulian

raspistill uses half-combine, (it uses MIPI_Camera SDK) supports full-combine but it does not go through ISP, so the image appears green.

If you want better image quality, you can use picamera to get the image, but it cannot get the full-view image. (I will provide a ROS example in the attachment)

If you want full-combine, you need to use stereo_depth_demo (MIPI_Camera SDK), but the calibration procedure in stereo_depth_demo is not very good, and it may take multiple attempts. You can try to calibrate with a small number of pictures, for example, 10.


so @wong how can i use the zip that you gave to me ? what do i need to do first ? and can i still fix the quality of the image right ?

Hi @AldifaJulian

The sample program I sent you uses picamera to get images, and the image quality should be the same as raspistill.
This sample program is a node of ROS, you can unzip the zip file, there is a README that describes how to install and use it.

@wong now i have another question about full-combine, so i already install the SDK Library, and followed the example, but i have error about this, what does it means and what should i do ? i have this error message when i used arducamstill and the image didn't appear

sorry @wong my problem about full-combine camera was already fixed, and now back to this problem, so can you give me solution, can i still use IMX219 module instead of the pi camera for depth mapping ? need your reply ASAP thank you

Hi @AldifaJulian

The image appears green because there is no ISP support, you can try to open the software white balance:

so i need to download the SDK Lib by make a git clone for those 2 programs ?

Hi @wong so for this link : cannot open the file, should i install first ? and what commands for install that on the terminal ? need reply ASAP Thank you

Hi @wong and for this link : is like this, what should i do even though i already installed v4l2 ?

@wong what should i do?

Hi @AldifaJulian

The codes in these two links give you a reference how to turn on software white balance.
You should be able to see how software_auto_white_balance is used when you open these two links:
camera.software_auto_white_balance(enable = True)