Problems installing libcamera python wrapper

I have been following the instructions from The pinned post from Dec.

I am having a bit of trouble installing the whl as per the directions
When I run python3 -m pip install ./libcamera-1.0.2-cp39-cp39-linux_armv7l.whl I get the following error:

Defaulting to user installation because normal site-packages is not writeable
Looking in indexes: https//, piwheels - Simple index
ERROR: ./libcamera-1.0.2-cp39-cp39-linux_armv7l.whl is not a supported wheel on this platform
With the same error with the cp27 versions for both the 1.0.1 and 1.0.2 packages

When I run uname -a I get

Linux rasberrypi 5.10.103-v8+ #1530 SMP PREEMPT Tue Mar 8 13:06:35 GMT 2022 aarch64 GNU/Linux

Is there no version of the package made for my kernal yet? do I have my system configured incorrectly?

I also have trouble compiling the libcamera_cpp_demo from the same topic. If someone believes this issues to be related I can elaborate, but it may be a topic of its own


hi, mirth

Currently this library is not compatible with 64-bit Raspberry Pi systems. We will make a library compatible with 64-bit systems.

Due to the new version of libcamera, some method names have been modified. As a result, libcamera_cpp_demo cannot be used on systems after Raspberry Pi kernel version 5.10.92.

You can refer to the modification method here to modify.

Modified Cpp Example: (5.1 KB)

That’s too bad about the python library then
These examples should help me make a good workaround for now
Thanks for the help, I look forward to the updates

Were you able to get around this error:

Unable to init server: Could not connect: Connection refused
terminate called after throwing an instance of 'cv::Exception'
  what():  OpenCV(4.5.5) /home/pi/opencv/modules/highgui/src/window_gtk.cpp:635: error: (-2:Unspecified error) Can't initialize GTK backend in function 'cvInitSystem'