Problem with communication between RASP and Image Sensor

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry Pi 3B+
4.Which instruction are you following?
5.Has your product ever worked properly?
Never worked
6.What problems are you experiencing?

I have a problem with my communication between Raspberry Pi 3 and Image Sensor from Sony. Unfortunately I cant tell what what is the exactly the part number because this is not released component yet. This is a confidential information in my work. I can say this is 8MPX sensor

I know that sensor is working correctly because in my company I have a some internal devices for testing. However I would like to make same additional work and try to connect this camera to my raspbarry pi. Im doing everything like is in the instruction (youtube link) but when im in /MIPI_Camera/RPI folder and trying to use this command ./arducamstill I have only this information:
Open camera…

Hardware platform: a020d3

init camera status = 4100
And there is no any option to show the screen from the camera.

What exactly does it mean? Do you have any suggestions?
7.What attempts at troubleshooting have you already made?
install libzbar-dev libopencv-dev
8.How would you like us to help you?
Any tips what can I try to do will be great