Pivariety cam imx230 strange behaviour

I am using Pivariety camera with the 2 raspberry pi. I did set everything such as drivers etc. a month ago. It was working fine but until yesterday I took the camera strips out from pi and camera. After connecting them again and on running libcamera-hello I get error no camera available. I also checked the cmd dmesg | grep arducam and it results in probe failed. I tried to reconnect the strip and readjust it many time but got the same error. I tried the same with raspberry pi (which also had drivers installed and tested with the camera) but got the same error. It took us whole two days to debug it. We restarted the pi many times if it can solve the problem. But, nothing solved the issue. Atlast, we tried to reinstall the driver from scratch and it started working. Why is this the case as I didn’t chnage anything in the OS as well.

Can you provide pics of cable connections and detailed pics of the modules?
We can confirm that there is no apparent hardware damage.