OwlSight Camera returns green image

  1. Where did you get the camera module(s)?
  2. Model number of the product(s)?
    OwlSight OV64A40
  3. What hardware/platform were you working on?
    Raspberry Pi CM4, 8GB RAM
  4. Instructions you have followed. (link/manual/etc.)
    64MP OwlSight - Arducam Wiki
  5. Problems you were having?
    The received jpg image is just green.

I am using a Raspberry Pi CM4 on a GPIO board.
The CM4 has a freshly installed bookworm OS with desktop. I executed sudo apt update, sudo apt upgrade. The kernel version is 6.1.73.

I tried both suggestions in /boot/firmware/config.txt ( dtoverlay=ov64a40,link-frequency=360000000 and dtoverlay=ov64a40,link-frequency=456000000)
but without success.

It works if I manually reduce the resolution:
libcamera-still -o test.jpg --width 4624 --height 3472

I did not manually install any drivers asuming the camera driver is included in the new bookworm OS.

What do I have to do to be able to capture the 64MP images?

1 Like

I’m dealing with the same issue, exactly. I’d love to get an answer.

We are working on this problem. It is supposed to be solved last year but I do not know why the Raspbery Pi did not upload the solution to the latest kernal.

@miar I just wanted to update you on what I’ve done to get it working so far. I got it to take a 64MP image in terminal, but not yet with a python script. IDK what your goals are but this way you will at least be able to take good images.

  • get latest version of Bookworm(fresh install, from a trusted source)
  • sudo apt-get update
  • sudo apt full-upgrade
  • sudo reboot
  • sudo nano /boot/firmware/config.txt
  • (add “dtoverlay=ov64a40, link-frequency=360000000” in the config.txt file at the bottom under the [all] header
  • Press CTRL+O
  • Press Enter
  • Press CTRL+X
  • sudo reboot
  • sudo SKIP_KERNEL=1 rpi-update f51e83aa02a132177efcf18215fcf8924d7b039f
  • sudo reboot

Let me know if this worked for you.

I think the command below will be more helpful:
sudo SKIP_KERNEL=1 rpi-update 545545d44d2f33cae473889b6e94687d578a89e9
If you want to capture 64mp full resolution pictures, I suggest that you can choose the Bookwork OS headless version. Besides, you also need to add the entry below in the config file under [all]:


Reboot to take effect.

BTW, I also like this jackie chan meme LOL.

thanks @Cornato and @Dion. I tried Dion’s suggestion:
sudo SKIP_KERNEL=1 rpi-update 545545d44d2f33cae473889b6e94687d578a89e9
and it worked.
Thank you very much.

Ok, I have it working now and I don’t want to mess it up. I don’t know enough about Linux and am worried using this command may mess it up. Do you suggest I use the command you posted in addition to what I’ve already done? I also have removed the cma-512 from my config.txt as I didn’t see it working.

I was able to get it to do what I needed via python script, I had to pause the video stream to capture an image and then resume the video stream. I used the picam2.switch_mode_and_capture_file command to get it to work. I don’t think the RPi4 video processing can handle multiple threads or something. I really don’t know I was just experimenting and found that it worked for me.