OV9281 RaspberryPi V4L2 driver is not working

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry Pi 4 CM IO board
4.Which instruction are you following?
5.Has your product ever worked properly?
Never worked
6.What problems are you experiencing?

so I just got the above mentioned camera module as Rev. B UC-599.

Since it’s stated that this module has official support on the rpi linux branch via the v4l2 subsystem, I was quite sad to not see it working.


I connected the module with the compute module 4 IO board through the CAM0 CSI-2 interface.
And I fitted the 2 jumpers on J6 for the I2C communication for CAM0.

Next, I added “dtoverlay=ov9281” to the config file, to enable the camera module.

Finally I booted the pi and checked the loaded driver with “modinfo ov9281”, and it is the one located at “/lib/modules/5.10.46-v7l+/kernel/drivers/media/i2c/ov9281.ko”. Everything as expected so far.

But checking the dmesg I see the following error:

[ 7.098148] ov9281 10-0060: Unexpected sensor id(d0fc2400), ret(-5)

And I also have no device at /dev/video0.

As you can see above, my kernel version is 5.10.46-v7l+


I see that the v4l2 driver here: https://github.com/raspberrypi/linux/blob/rpi-5.10.y/drivers/media/i2c/ov9281.c only supports a 2 lane MIPI CSI-2 interface to the camera. But I can physically see that the module I have has only 1 data lane, and 1 clock lane. So it isn’t surprising to me that is doesn’t work.


Here is a picture showing that only 1 differential data lane and 1 clock lane is electrically connected. The picture is accurate to the real module.

The mapping can be found here: https://www.robotshop.com/media/files/content/a/adu/pdf/arducam-ov9281-1mp-mono-global-shutter-mipi-camera-raspberry-pi-datasheet.pdf

You can see that the differential pair on the very right is data lane 0, and then there is the clock lanes further left to it.What I don’t understand is, how is the claim justified that it has a working v4l2 driver ? Am I missing the driver ? Where is it ?
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?
through the forum, by providing a working v4l2 driver

Our hardware engineer has ensured that this version is 2 lanes mode and the other two lines is on the back of the board. This is a two-layer PCB board.
As normal, you can use rpi official ov9281 driver. Please check your hardware in detail and retry .