OV9281 partially working on RPi4

1.Which seller did you purchase the product(s) from?
Same Pi works with other RPi cameras both official and unofficial (unofficials are installed on different SD cards so there aren’t any firmware compatibility issues). Read through several threads here, but those seem to have issue either because of 8GB version or getting the Pi to recognize the camera is plugged in.
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Rpi 4B (kernel 5.4.72-v71+) 2GB version
4.Which instruction are you following?
https://www.arducam.com/docs/cameras-for-raspberry-pi/migrated/ov9281-1mp-global-shutter-raspberrypi-camera/ and https://github.com/ArduCAM/MIPI_Camera/tree/master/RPI
5.Has your product ever worked properly?
Never fully worked
6.What problems are you experiencing?
Accessing the camera stream hangs.

When I follow at https://www.arducam.com/docs/cameras-for-raspberry-pi/migrated/ov9281-1mp-global-shutter-raspberrypi-camera/

Everything works (no errors and ls /dev/video0 returns the device) until I reach the frame rate test

$ v4l2-ctl --stream-mmap --stream-count=-1 -d /dev/video0 --stream-to=/dev/null

which give no output, just hangs with blinking cursor.

when running through the guide at https://github.com/ArduCAM/MIPI_Camera/tree/master/RPI

I can follow with no errors until I enter:

$ ./arducamstill -t 0 -m 1 -awb 1 -ae 1

which after several seconds gives
“Open camera…
Hardware platform: b03112
Found sensor ov9281 at address 60”
And then hangs

7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?
I would like to get the camera working. Don’t know if I recieved a DOA or seomthing else.