OV9281 module not working with RPI3

I was following this tutorial to make Arducam ov9281 (UC-599) work with my Rpi3 (kernel 5.4.51-v7l+).

I do see the device at /dev/video0 but i get no response at all when calling v4l2 -

v4l2-ctl --stream-mmap --stream-count=-1 -d /dev/video0 --stream-to=/dev/null

I also tried installing the SDK from github and also nothing outputs actual video / capture images. As an example, the ‘preview’ demo app runs properly (with no errors) but no video is displayed at all.

Any idea what would cause this? Am I missing something?


We find the same issue on Pi3, TH rpi official has optimized the issue on PI4 platform. ON pi3, please use our MIPI_Camera driver firstly. https://github.com/ArduCAM/MIPI_Camera.git



I already tried the MIPI_Camera driver - with no success (on RPI 3). Is there any way to debug this?


Using before using MIPI_Camera driver, you should comment the dtoverlay=ov9281 .

Because the two drivers can’t work at the same time.

Just open the /boot/config.txt and comment or delete the dtoverlay=ov9281


Thanks, that helped…

You are welcome. Let me know if you need more help.


May I expect any limitation with getting 720p @ 120fps using this SDK?

I could only get this frame rate with 480p, by setting V4L2_CID_EXPOSURE to 8ms, but at 720p it didn’t really seem to make a difference. Max fps was 60.

Is there any example for high fps capture?


You can try to use 2lan raw8 configuration.