OV9281 Data length error


I run the python demo code with “OV9281_MIPI_1Lane_RAW10_8b_1280x800_40fps.cfg” file on my raspberry pi and receive the following error message.

('Error capture image, rtn_val = ', 65316L)
fps: 16 /s

I ran the same python code on windows. It works without any error at 40 fps with the same cfg file. I have read that “capture” thread is not enough fast to read data from the buffer. As far as I understand I have to modify the cfg file but I did not find any information about which register values I have to change. I would like to try capturing images in 640x480 resolution at 25 or 30 fps and see if the raspberry pi is able to handle with it. I would be happy if I find a document that clearly explains the registers.

Hardware: Raspberry pi 3 model A+

Camera module: UC 599

USB shiled: UC391 Rev.E

Thanks in advance.

Hello @josem ,

Currently we do not have the corresponding configuration, if you need we can modify it for you. If you want 640x480 resolution will lose the viewing angle, because 640x480 will be cropped from the maximum resolution. 640x400 will not lose the viewing angle, because of this It can be obtained through binning.
By the way, why don’t you use our MIPI_Camera SDK on RPI? Using MIPI_Camera SDK you can directly connect the camera to the CSI2 interface of RPI, it can get higher speed.

This is a 640×400 30fps configuration:



Thank you very much for the config file. It was working at varying FPS between 17 and 25. Now it works at constant 31 fps. Still less than 40 but I will try it also with the ribbon cable. I did not have it before.

Hi @josem ,

Is there any progress?