OV9281 and Raspberry PI 4 model B 8gb: camera status 4100

<label style=“color:blue”>1.Which seller did you purchase the product(s) from?</label><br>I tried the Pi4 additional step for the GPIO. That didn’t help. I increased my GPU to 180MB. Reconnected the cable. Installed the full version of opencv.<br><label style=“color:blue”>2.The Model number of the product(s) you have purchased?</label><br>https://www.amazon.co.uk/gp/product/B085VQ9BBY/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1<br><label style=“color:blue”>3.Which Platform are you using the product(s) on?</label><br>raspberry pi 4B 8gb<br><label style=“color:blue”>4.Which instruction are you following?</label><br>initially your quick start guide https://www.arducam.com/docs/cameras-for-raspberry-pi/migrated/ov9281-1mp-global-shutter-raspberrypi-camera/<br><label style=“color:blue”>5.Has your product ever worked properly?</label><br>it works when using v4l2 but not with teh MIPI_Camera/RPI/ apps.<br><label style=“color:blue”>6.What problems are you experiencing?</label><br>Hi, I can not run any of the apps under MIPI_Camera/RPI/, i get:

[email protected]:~/MIPI_Camera/RPI $ ./list_format
Hardware Platform: d03114
Can’t detected the support hardware version
Couldn’t open I2C device
init camera status = 4097

I used to get 4100, but i’ve just used your library without the encryption verification (https://www.arducam.com/forums/topic/imx298-and-raspberry-pi-4-model-b-camera-status-4100/)<br>

wrong key… wasn’t finished.

[email protected]:~/MIPI_Camera/RPI/utils $ ./camera_i2c
setting GPIO for board revsion: d03114
Raspberry Pi3B / Pi3B+ / 3A / 4B(1G/2G/4G)
./camera_i2c: 137: ./camera_i2c: ./rpi3-gpiovirtbuf: Permission denied
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: 60 – – – 64 – – – – – – – – – – –
70: 70 – – – – – – –
[email protected]:~/MIPI_Camera/RPI/utils $

 

It looks like the 8GB ram version of rpi4 is not supported… is that the problem?

Thanks

Hello,

Yes, you are right. the lib you are using does not support the new hardware platform (Pi4 8G)

We have updated our lib to support that board. Please download our new lib to retry and let me know if you need more help.

 

Hi, tried last sunday quickly on my existing SDcard, no luck with the new library.

Started from scratch, new SD card, new OS, then followed instruction (sorry for teh lengthy paste):

https://www.arducam.com/docs/cameras-for-raspberry-pi/mipi-camera-modules/camera-userland-driver-sdk-and-examples/

4100

Did
https://www.arducam.com/docs/cameras-for-raspberry-pi/migrated/ov9281-1mp-global-shutter-raspberrypi-camera/

Did
ls /boot/overlays/ov9281.dtbo
got
[email protected]:~/MIPI_Camera/RPI/utils $ ls /boot/overlays/ov9281.dtbo
/boot/overlays/ov9281.dtbo

Yavta worked

Back to MIPI…
[email protected]:~/MIPI_Camera/RPI/utils $ cd …
[email protected]:~/MIPI_Camera/RPI $ ./arducamstill -?
Open camera…
Hardware platform: d03114
Found sensor ov9281 at address 60
init camera status = 4100
[email protected]:~/MIPI_Camera/RPI $

Did
https://github.com/ArduCAM/MIPI_Camera/tree/master/RPI

reboot

get:
[email protected]:~ $ cd MIPI_Camera/RPI/
[email protected]:~/MIPI_Camera/RPI $ ./arducamstill -?
Open camera…
Hardware platform: d03114
Found sensor ov9281 at address 60
init camera status = 4100
[email protected]:~/MIPI_Camera/RPI $

[email protected]:~/MIPI_Camera/RPI/utils $ ./camera_i2c
bash: ./camera_i2c: Permission denied
[email protected]:~/MIPI_Camera/RPI/utils $

had to assign execute permission to camera_i2c
[email protected]:~/MIPI_Camera/RPI/utils $ chmod +x camera_i2c
[email protected]:~/MIPI_Camera/RPI/utils $ ./camera_i2c
setting GPIO for board revsion: d03114
Raspberry Pi3B / Pi3B+ / 3A / 4B(1G/2G/4G)
./camera_i2c: 137: ./camera_i2c: ./rpi3-gpiovirtbuf: Permission denied
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: 60 – – – 64 – – – – – – – – – – –
70: 70 – – – – – – –
[email protected]:~/MIPI_Camera/RPI/utils $ ^C

not working:

[email protected]:~/MIPI_Camera/RPI $ ./list_format
Found sensor ov9281 at address 60
init camera status = 4100

 

I must be missing something obvious… :slight_smile: thanks for your help

Eric

Hello,

Any update on this please?

I am also trying to use the camera on a Raspberry PI 4 8G RAM.

Thanks.

 

Hello,

Using MIPI_Camera library (arducamstill), Please open the /boot/config.txt and comment the dtoverlay=ov9281 then reboot and try it again. Let me know if you need more help.

 

Hi,

no luck…

[email protected]:~/MIPI_Camera/RPI/utils $ ./camera_i2c
setting GPIO for board revsion: d03114
Raspberry Pi3B / Pi3B+ / 3A / 4B(1G/2G/4G/8G)
Set state of 133 to 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: 60 – – – 64 – – – – – – – – – – –
70: 70 – – – – – – –
[email protected]:~/MIPI_Camera/RPI/utils $

[email protected]:~/MIPI_Camera/RPI/utils $ ./camera_i2c
setting GPIO for board revsion: d03114
Raspberry Pi3B / Pi3B+ / 3A / 4B(1G/2G/4G/8G)
Set state of 133 to 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: 60 – – – 64 – – – – – – – – – – –
70: 70 – – – – – – –
[email protected]:~/MIPI_Camera/RPI/utils $

 

it says /8G in the line above because i added it… am i using the wrong library?

Thanks

Eric

The camera you bought is not arducam’s product,Please contact the camera supplier for technical support

oh my god you’re right! I googled arducam global shutter and clicked on amazon link without thinking twice… sorry about that, can’t believe i’ve wasted so much of your time and mine … back to google and buy the real one then. Thanks for your support

You welcome. Let me know if you need more help.