open fail, rtn_val = 65281 using IMX 291 on raspberry Pi

1.Which seller did you purchase the product(s) from?
Local online store (
2.The Model number of the product(s) you have purchased?
USB Shield2 Rev E and IMX 219 board B102
3.Which Platform are you using the product(s) on?
Raspberry Pi
4.Which instruction are you following?
installing arducam config parser and install libusb version 1.0.24
5.Has your product ever worked properly?
Worked on Windows
6.What problems are you experiencing?
Hi there,

I already trying python script for streaming video for my board, and it can streamed image, but when I run on raspberry, it always failed to open with return value 65281.

I am using Python 3.7.3 on Raspberry Pi.

Could you give me clue what the problem is.

Thank you
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?

Hi there,

Here is additional information for what I’ve done :

  • I tried the python demos on Windows and it worked

-On my raspi (4B), the command ArduCam_scan could detect the camera (found device).(I already installed arducam config parser, latest libusb, have opencv (ver 4.2.0)

  • On ArduCam_open and ArduCam_autoopen, always return 65281 (USB_CAMERA_USB_CREATE_ERROR)

  • Between scanning and opening, already have delay > 2s

  • Not sure about the, I trying using, with the same result.

  • I am using IMX219_MIPI_2Lane_RAW10_8b_640x480_30fps.cfg configuration file

Please advise, is there any other thing I could try.




Sorry to reply to you so late, there is a problem with our forum service system, it has been fixed now, has your problem been solved? Please feel free to let me know if you need more help.