No cameras available: Jetson nano, IMX477

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?

  • Jetson nano B01
  • NVIDIA Jetson nano Developer Kit - Jetpack 4.6 [L4T 32.6.1]
  1. What hardware/platform were you working on?

gst-launch-1.0 nvarguscamerasrc sensor-id=$SENSOR_ID ! “video/x-raw(memory:NVMM),width=1920,height=1080,framerate=$FRAMERATE/1” ! nvvidconv ! nvoverlaysink

Setting pipeline to PAUSED …

Pipeline is live and does not need PREROLL …

Setting pipeline to PLAYING …

New clock: GstSystemClock

Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:725 No cameras available

Got EOS from element “pipeline0”.

Execution ended after 0:00:00.004294877

Setting pipeline to PAUSED …

Setting pipeline to READY …

Setting pipeline to NULL …

Freeing pipeline …

  1. Instructions you have followed. (link/manual/etc.)

cd ~
chmod +x
./ -m imx477

  1. Problems you were having?
    Error when launching the camera after installing the driver. It says there is no camera available to run. Try changing the sensor ID, the FPS, and the executable code, and the result is the same.

  2. The dmesg log from your hardware?
    [ 1.335931] imx477 7-001a: tegracam sensor driver:imx477_v2.0.6
    [ 1.636289] imx477 7-001a: imx477_board_setup: error during i2c read probe (-121)
    [ 1.643873] imx477 7-001a: board setup failed
    [ 1.648346] imx477: probe of 7-001a failed with error -121
    [ 1.648699] imx477 8-001a: tegracam sensor driver:imx477_v2.0.6
    [ 1.949032] imx477 8-001a: imx477_board_setup: error during i2c read probe (-121)
    [ 1.956656] imx477 8-001a: board setup failed
    [ 1.961120] imx477: probe of 8-001a failed with error -121

  3. Troubleshooting attempts you’ve made?

  1. change the camera connector; I had one more camera kit, so I tried changing the connector that plugs into the camera port on the Jetsonano.
  2. GitHub - RidgeRun/NVIDIA-Jetson-IMX477-RPIV3: NVIDIA Jetson IMX477 HQ RPI V3 camera driver
    I rebuilt the camera kernel according to the manual, but after rebooting, I got a non-passing error on the NVIDIA screen.
  1. What help do you need?
    I need another workaround that allows me to use the camera.


The camera is not detected, can you see your hardware connection diagram? Especially the two ends of the flex cable connection.

Here are my hardware connections.


I saw you used an hdmi extension cable, can the camera be detected by directly connecting the camera to the jetson?

Yes, it’s the same if you change the connection method.


I’m sorry I forgot that you can’t disassemble the kit, you still connect the camera according to the original method.

I want you to try another hdmi cable.
Also can I ask if your Jetson carrier board is official?

Yes, I bought it from nvidia officialhome and followed the official manual for jetpack as well. Same thing with changing the hdmi. Are there any issues with the installed drives?

I reinstalled with jetpack version 4.5 to install the kernel and it worked! Now the camera is still showing live, how do I shut it down, and do you know of any commands for the camera?


Please use the commands in my link above.