Multi-camera board and cm4: no cameras found

  1. Where did you get the camera module(s)?

direct from uctronics

  1. Model number of the product(s)?

B012001 - Multi-camera board v2.2

  1. What hardware/platform were you working on?

Raspberry Pi CM4 2 GB, 16 GB eMMC
Multi-camera board, 4-port
4x imx708

  1. Instructions you have followed. (link/manual/etc.)

Quick Start Guide for Multi-Camera Adapter Board - Arducam Wiki

  1. Problems you were having?

No cameras found with Multi-camera adapter plugged into CAM0 port of CM4 carrier board

  1. The dmesg log from your hardware?

dmesg | grep imx708
(no output)

  1. Troubleshooting attempts you’ve made?


  1. What help do you need?

Hi @scruss
Sorry for the late reply…
I have make the multiplexer + imx708 work on Pi 5’s CAM 0 port, which should be same for CM4. I only connect one imx708 to Multiplexer, but it has no difference between one camera connected and four cameras connected.

  • Hardware connection
    Hhhh, the CAM 1 port is broken and I do not know how to fix it :joy:

  • Software config
    Add the entry below in the config.txt file:



  • Preview
libcamera-still -t 0

I think modifying the config.txt file like this will make your setup work:

1 Like

Thanks! It seems that changing to the CM4’s other camera port worked as expected.

Hi Scruss,

I am having similar problems but with a Raspberry Pi 4, and I am curious if our problems are related.

In order to get your camera to work did you just have to add the ,cam0 to the end of the dtoverlay? Does the CM4 have multiple camera CSI ports like the Pi 5? Do you have all four ports on the camera connected to actual cameras?


No, yes and yes - in that order.

What is confusing about the multi-camera adapter is the order of the cameras. For me, Camera 0 is the port market “Camera D”

Oh that is interesting about the Camera D = Camera 0. I just tried moving the camera, but no luck for me it still is not seeing a camera. Thanks for that tip though!

So in order for you to get it to work you just had to switch the physical camera port you were using on the CM4?


Yes, but that only applies to the CM4. On a Raspberry Pi 4, I had these lines in my /boot/firmware/config.txt


and all four cameras were found. The problem I had in Multi-Camera Adapter Board + 4x Raspberry Pi v3 (wide) cameras = No cameras available was that I’d put the multiplexer - Raspberry Pi cable in the wrong way up. It goes in the other way up from the camera cables. There’s a picture in there how it should look.

Since this topic was marked “solved” you’d be better off asking your own new question if you continue to have problems. Arducam staff may not monitor solved questions.