Multi-Camera Adapter Module V2.2 with 2 OV5647 not working

I have two OV567 cameras connected to the Adapter Module 2.2 (bought in roboshop)

I have a normal camera and a night vision camera connected to the module.

When running the from the Arducam Repo, only the first camera works, and I don’t get a feed from the second camera connected.

I tried swapping the cameras and the same happens (only the camera on port A works).

Screenshot init_camera

I’ve tried also the and only the first camera responds.


Any clues what might be wrong? Thanks in advance

Hello, is used to test four cameras, if you only test two, you need to modify the script.Please attach me your hardware connection and I will help you check it in detail.



I have one camera connected to port A and the other to port C.
I commented the lines concerning the unused ports.

The code is the following:

import RPi.GPIO as gp
import os


gp.setup(7, gp.OUT)
gp.setup(11, gp.OUT)
gp.setup(12, gp.OUT)

gp.setup(15, gp.OUT)
gp.setup(16, gp.OUT)
gp.setup(21, gp.OUT)
gp.setup(22, gp.OUT)

gp.output(11, True)
gp.output(12, True)
gp.output(15, True)
gp.output(16, True)
gp.output(21, True)
gp.output(22, True)

def main():
print(“Start testing the camera A”)
i2c = “i2cset -y 1 0x70 0x00 0x04”
gp.output(7, False)
gp.output(11, False)
gp.output(12, True)
#print(“Start testing the camera B”)
#i2c = “i2cset -y 1 0x70 0x00 0x05”
#gp.output(7, True)
#gp.output(11, False)
#gp.output(12, True)
print(“Start testing the camera C”)
i2c = “i2cset -y 1 0x70 0x00 0x06”
gp.output(7, False)
gp.output(11, True)
gp.output(12, False)
#print(“Start testing the camera D”)
#i2c = “i2cset -y 1 0x70 0x00 0x07”
#gp.output(7, True)
#gp.output(11, True)
#gp.output(12, False)

def capture(cam):
cmd = “raspistill -o capture_%d.jpg” % cam

if name == “main”:

gp.output(7, False)
gp.output(11, False)
gp.output(12, True)


Only the preview of camera A shows up, and nothing happens with camera C.
I also tried connecting the second camera to port B but the same happens.
I really need to get this setup running, thanks in advance!


The script seems right.

Changing camera A to C which need to write the

i2c = “i2cset -y 1 0x70 0x00 0x06”
gp.output(7, False)
gp.output(11, True)
gp.output(12, False)

Can you measure the level status of this single pin now? What’s more, are you sure the i2c bus is normal?


The pins 7, 11, 12 are enabled/disabled correctly. How can I check that the i2c is working properly?

when I run the command: sudo i2cdetect -y 1
I get always the following result:

i2c detect

even when the Adapter is disconnected. Is that normal?
The i2c is enabled through the raspi-config



It is not normal, it seems the i2c bus is not pull up.

As nornal, if you does not connect any devices, you can’t detected and address.

Is it convenient for you to use teamviewer? I can remote help you using teamviewer. If so we can make an appointment.


Yes, teamviewer works for me.

When is a good time for you?


China Beijing time from 8 to 22:00 is OK. Please tell me your free time.


Does 20:00 beijing time of tomorrow (wednesday 22 july) works for you?


Great. If you are free now. I have time now.Please tell me your id and password though my email . my email address is [email protected]

I tried the code in another RPI and it worked.
I am guessing the i2c communication is broken in my first RPI.

I’ll try to see if it can be fixed.
Thanks for you help.