Multi Camera Adapter module V2.2 Frame.dtype=np.unit8 Error

1.Which seller did you purchase the product(s) from?

2.The Model number of the product(s) you have purchased?
Arducam Multi Camera Adapter module V2.2 for Raspberry Pi 4 (Arducam MIPI Compatible) EEP4215
3.Which Platform are you using the product(s) on?
Raspberry Pi 4B
4.Which instruction are you following?
online documentation, video tutorial
5.Has your product ever worked properly?
work intermittently
6.What problems are you experiencing?

I have a Arducam Multi Camera Adapter module v2.2 using with Raspberry pi 4B with Python 2.7.16 version, OpenCV 4.5.0 and Numpy 1.16.2. I followed the documentation online and tutorial video. However, I need the python script because I have other things to control with the raspberry pi, but I cannot get the python scripts to work.

I did enable the raspi-config for I2C and camera, and also add (dtparam=i2c_vc=on) to the end line in sudo nano /boot/config.txt. I tested the sudo chmod +x line for the files in the python folder and also tested code working good but I can’t run and got error in programming .

Thank you.
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?


I have a v2.2 and I was able to get 4 cameras working with the C++ previewOpencv executable. However, I cannot get the python scripts working. Could you send me the documentation to run the please?

Thank you.


Sorry for my late reply. Have you solved your issue?


Python demo:

Thank you for your inquiry, we have also updated our documentation.

You can also follow the doc to run the Python demo: