Modify cfg file

I am currently working on the file ArduCAM_108MP_MIPI_2Lane_RAW8_12000x9000_1.4fps.cfg on github.
I want to delay the fps of the camera by modifying the cfg file arbitrarily.
Is this easily possible?
If possible, can you tell me which part to modify?

@LSH

Do you want to modify the frame rate?

1
0x0342 is HTS, 0x0340 is VTS

If you want higher frame rates, you can reduce their values. If you want a lower frame rate, you can increase their value.
Please don’t adjust them too much, they have a certain range of values.

The reason I’m asking this question is to get a perfect image
In addition to printing the image, we want you to save it and use it.
I often get images that are not complete, or even images that are repeated in certain parts of one image



So even if we lowered the fps, we needed a way to get a complete image.
But I found out that this had nothing to do with fps.
I think the image was already broken at the time of capture and received.
Is there a way to solve this?

@LSH

I will test it again tomorrow, please wait.

@LSH

After testing I also found this problem. I also tested other platforms (windows and linux), there is no problem on windows, but there is a problem on linux. This has to do with the sdk design, we recommend using the c++ example, it will work better, but there is also this problem, I found that it works better when it is stationary for a long time.

c++ demo

It certainly worked as you said.
However, I still think the problem has not been solved perfectly.
So I need a new cfg file to increase stability while maintaining high quality.
64MP cfg would be enough.
Do you have a cfg file or a guide to write a cfg file for taking a 64mp image with a 108mp camera at Jetson nano?

@LSH

Yes, optimizing the sdk is a goal in our long-term plan.

I understand your current state.But sorry, currently 108MP does not open the manual, if you need it, you can try to contact [email protected]

@LSH

We are also currently discussing your problem and if there is a new solution, I will let you know right away.

image
I saw this FAQ when I bought it.
108MP

Did I misunderstand?
If not, I think this part needs to be revised.
And thank you very much for your efforts to solve this problem.
I don’t have much time, so I hope there will be a solution soon.

Thank you again for your help for me. If you have any news, please reply to this article

@LSH

First of all, this part needs to be revised. I am sorry that this has caused you misunderstanding, and I have arranged for the relevant staff to make changes.

We have started to put this discussion on today’s agenda and will give you an accurate result today.

@LSH

I just discussed this issue with our chief engineer.
We will write a new program just for you and hope you will be satisfied.
Please wait a moment, this won’t take long

Thank you very much for the fact that this seems solvable.
I’ll wait until I get any news.
I hope you have good news.

@LSH

We changed the architecture. Bad images are discarded on our new architecture, but there are still some performance issues that need to be optimized. We also need to make this new architecture into sdk in the future, and release it after everything is ready.

Is it still available on Jetson Nano?
I purchased this module for use by Jetson Nano.

Optimization is a very difficult and time consuming task. Can you tell me the approximate time when it will be completed?

@LSH

This is optimized for linux, so the theory is all valid. The previous framework was flawed in linux.
Yes, this is not a short-term job, we are going to start testing various linux platforms (including Nano) later, I will let you know after the Nano testing.

The time is not yet certain, and we need to organize several meetings to discuss and finalize this matter.

Thank you again for your efforts and hope for good news.
Please contact me when the test file is ready

@LSH

We made a sdk, you can try it, but it is on x86-64 platform.Mainly solve the problem on linux system.

rely

curl -s --compressed "https://arducam.github.io/arducam_ppa/KEY.gpg" | sudo apt-key add -
sudo curl -s --compressed -o /etc/apt/sources.list.d/arducam_list_files.list "https://arducam.github.io/arducam_ppa/arducam_list_files.list"
sudo apt update
sudo apt install arducam-config-parser-dev arducam-usb-sdk-dev
sudo apt install -y cmake
sudo apt install -y build-essential
sudo apt install -y libusb-1.0-0-dev

SDK

use

unzip arducam_usb_sdk_test.zip
cd arducam_usb_sdk_test
mkdir build
cd build
cmake ..
make
wget https://raw.githubusercontent.com/ArduCAM/ArduCAM_USB_Camera_Shield/master/Config/USB3.0_UC-593%20Rev.C/MIPI/ArduCAM_108MP/ArduCAM_108MP_MIPI_2Lane_RAW8_12000x9000_1.4fps.cfg
sudo ./usb_test ArduCAM_108MP_MIPI_2Lane_RAW8_12000x9000_1.4fps.cfg dma

If you think this sdk is satisfactory, please let me know, we will continue to develop

@LSH

nano

sdk:

use

tar avxf arducam_usb_sdk_test_arm64.tar.xz
cd arducam_usb_sdk_test_arm64
cd build
cmake ..
make
wget https://raw.githubusercontent.com/ArduCAM/ArduCAM_USB_Camera_Shield/master/Config/USB3.0_UC-593%20Rev.C/MIPI/ArduCAM_108MP/ArduCAM_108MP_MIPI_2Lane_RAW8_12000x9000_1.4fps.cfg
sudo ./arducam_usb_sdk_test ArduCAM_108MP_MIPI_2Lane_RAW8_12000x9000_1.4fps.cfg dma
1 Like