Libcamera produces "Illegal Instruction" error

Using an IMX462 low light camera on a rPi zero W

I just got an IMX462 low light camera and installed everything on a rPi zero w and when I run libcamera-still or libcamera-vid I get an Illegal Instruction error.

Installation steps:

Dmesg output:

$ dmesg|egrep ardu
[ 27.956358] arducam: loading out-of-tree module taints kernel.
[ 28.020178] arducam-pivariety 10-000c: firmware version: 0x10002
[ 33.130938] arducam_vddl: disabling
[ 33.130979] arducam_vdig: disabling
[ 33.131003] arducam_vana: disabling

Running libcamera apps:

[email protected]:~ $ libcamera-still -o test.jpg
Illegal instruction
[email protected]:~ $ libcamera-vid -t 10000 --width 1920 --height 1080 -o test.h264
Illegal instruction

Hi @tve

We do not recommend using libcamera on Pi Zero, if you want to try, please refer to:
https://github.com/raspberrypi/documentation/issues/1902

Thanks for the info. I’ll see whether compiling libcamera from source per the docs makes ti work. If not, I’ll have to use a different rPi model…

I managed to compile libcamera and libcamera-apps from source. Good news it doesn’t crash anymore. Bad new is it doesn’t work… Can you tell from the error messages what I’m missing?

$ libcamera-still -o test.jpg
[10:58:52.458842179] [5270]  INFO Camera camera_manager.cpp:294 libcamera v0.0.0+2810-e0704e97
[10:58:52.495993013] [5272]  WARN CameraSensor camera_sensor.cpp:197 'arducam-pivariety 10-000c': Recommended V4L2 control 0x009a0922 not supported
[10:58:52.514176932] [5272]  WARN CameraSensor camera_sensor.cpp:249 'arducam-pivariety 10-000c': The sensor kernel driver needs to be fixed
[10:58:52.517555917] [5272]  WARN CameraSensor camera_sensor.cpp:251 'arducam-pivariety 10-000c': See Documentation/sensor_driver_requirements.rst in the libcamera sources for more information
[10:58:52.558142736] [5272]  WARN CameraSensorProperties camera_sensor_properties.cpp:109 No static
properties available for 'arducam-pivariety'
[10:58:52.561608721] [5272]  WARN CameraSensorProperties camera_sensor_properties.cpp:111 Please consider updating the camera sensor properties database
[10:58:52.567082696] [5272]  WARN CameraSensor camera_sensor.cpp:403 'arducam-pivariety 10-000c': Failed to retrieve the camera location
[10:58:53.071051448] [5272] ERROR IPAProxy ipa_proxy.cpp:149 Configuration file 'arducam-pivariety.json' not found for IPA module 'raspberrypi'
Open i2c bus error: No such file or directory
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::property_tree::json_parser::json_parser_error> >'
  what():  <unspecified file>: cannot open file
Aborted

Hi @tve

It seems that dtparam=i2c_vc=on is not added in /boot/config.txt

Thanks for the suggestion! That line was indeed missing, I must have not seen it int the indstructions. However, I added the line, rebooted and still get the same errors. The one that actually concerns me the most is the ERROR IPAProxy ipa_proxy.cpp:149 Configuration file 'arducam-pivariety.json' not found for IPA module 'raspberrypi', do you know where that json file is supposed to get produced?

Hi @tve

You don’t need to worry about this line, when it can’t find this file, the program will read it on the device.

By the way, you only need to recompile libcamera-apps, you can use the libcamera provided by us.

Hello I experience the same problem. How to recompile the libcamera-apps ?
Thanks in advance

This problem should have been fixed in the latest version, if you want to compile libcamera-apps, please refer to: