IMX519 has some error

  1. Where did you get the camera module(s)? Waveshare Online Stor

  2. Model number of the product(s)? IMX519-78

  3. What hardware/platform were you working on? Raspberry Pi 4B

  4. Instructions you have followed. (link/manual/etc.) Arducam Website

  5. Problems you were having? Has some errors when using

  6. The dmesg log from your hardware?

Made X/EGL preview window
[0:49:21.767672536] [7349] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3897-c3c878a9
[0:49:21.824551030] [7351] WARN CameraSensorProperties camera_sensor_properties.cpp:174 No static properties available for ‘imx519’
[0:49:21.824617903] [7351] WARN CameraSensorProperties camera_sensor_properties.cpp:176 Please consider updating the camera sensor properties database
[0:49:21.839468962] [7351] WARN RPI raspberrypi.cpp:1280 Mismatch between Unicam and CamHelper for embedded data usage!
[0:49:21.840445221] [7351] ERROR DelayedControls delayed_controls.cpp:87 Delay request for control id 0x009a090a but control is not exposed by device /dev/v4l-subdev0
[0:49:21.840708046] [7351] INFO RPI raspberrypi.cpp:1404 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media0 and ISP device /dev/media2
[0:49:21.841580746] [7349] INFO Camera camera.cpp:1035 configuring streams: (0) 2328x1748-YUV420
[0:49:21.842083635] [7351] INFO RPI raspberrypi.cpp:765 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format:

  1. Troubleshooting attempts you’ve made? Reinstalling the drivers

  2. What help do you need? I need to eliminate the warnings and errors.

While I use a camera not manufactured by Arducam, the drivers and packages work for me. My only concern are the 3 warnings and 1 error that always show when I use the camera. Occasionally, I cannot get to use the camera because of all the errors (which I manage by restarting the Pi).