IMX477_Stereo Null Object


I have 3 brand new kits of the arducam B0265N stereo imx477s.
I am trying to use them with a jetson-xavier nx developer kit (emmc) on jetpack 4.5 (nvidia-l4t-kernel-t194-4.9.201-tegra-32.5.2), and have installed the imx477_stereo driver.

The board binds correctly at startup:

However, running the test command (or any of the preview commands) results in the following:

I have tried multiple B0265N kits on multiple jetsons and all display the same behavior. I have also tried the instructions regarding testing each channel, and this resulted in again an identical gst error.

Any further troubleshooting steps or advice would be much appreciated.



Please reinstall the driver, we did the update yesterday.

Hi Edward,

I completely removed the driver with sudo dpkg -r arducam-nvidia-l4t-kernel, then re-downloaded the automatic installation script in a new folder and installed the imx477_stereo driver. I am still seeing exactly the same error as my previous post however.



please contact [email protected], post a link to the forum and we will arrange to upgrade the firmware for you.