IMX477 on Jetpack 6

Hello, are IMX477 kernels available for jetpack6? The forum does not have a clear answer and the jetpack 5 drivers do not work for jetpack 6. The specific camera I am using is linked below.

Thanks for your hard work and help!


I would like to know what Jetson devices you are using. Is it the Jetson Nano/Nx or the Jetson Orin series?

Hi, I am using the Jetson Orin Nano.

I hope you have a good weekend.
I attached the driver file in the link below.

Please download it on your Jetson Orin Nano and run the command below to install it:

sudo dpkg -i arducam-nvidia-l4t-kernel-t234-nx-5.15.136-tegra-36.3.0-20240521145743_arm64_imx477.deb

Hi should this driver also work with this camera?

I’m running Jetson Orin Nano 8GB Dev board with Jetpack 6. However after downloading the above driver, I have no devices in /dev/video* and I have a IMX477 probe error in dmesg. I have tried both arducam and Nvidia Jetson-io tools and tried with both IMX477-A and IMX477-C with the device in Cam0 and the device in Cam01 port. Any suggestions?

The driver is supposed to work with the camera you mentioned as well.

Have you ever installed the camera driver instead of just downloading the driver to your Jetson Orin Nano?

Thanks. I downloaded and ran the below:

sudo dpkg -i arducam-nvidia-l4t-kernel-t234-nx-5.15.136-tegra-36.3.0-20240521145743_arm64_imx477.deb

It returns some logs such as:
cannot access nv_imx477.ko.bak

Then says “installing” and then returns empty response without error

Thanks for the feedback.
Could you please post all the logs it returned?

I’m getting same issue on jetson orin jetpack 6.3 L4T R36.3

not that I solved the issue BUT…
sudo apt install v4l-utils
will move you to the next step for installing IMX477 on webpage…

1 Like

Great. Please update here if you have faced any problems.