IMX477 camera not work to get 4K image on Jetpack 5.0.2

I used a IMX477 camera(SKU:B0251) on a Jetson xavier NX with Jetpack 4.4 and it worked fine.
I recently upgraded version of Jetpack to 5.0.2 and the camera no longer works properly.
It works in FullHD mode, but if I change it in 4K mode, it stops working.

Is there any way to capture 4K image on the Jetpack 5.x environment?

The error message I got is as follows.

gst-launch-1.0 nvarguscamerasrc sensor-id=$SENSOR_ID ! \"video/x-raw(memory:NVMM),width=4032,height=3040,framerate=$FRAMERATE/1\" ! nvvidconv ! \"video/x-raw(memory:NVMM),width=1920,height=1080,framerate=$FRAMERATE/1\" ! nvvidconv ! xvimagesink

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
GST_ARGUS: Creating output stream
CONSUMER: Waiting until producer is connected...
GST_ARGUS: Available Sensor modes :
GST_ARGUS: 4032 x 3040 FR = 20.000000 fps Duration = 50000000 ; Analog Gain range min 1.000000, max 22.250000; Exposure Range min 13000, max 683709000;

GST_ARGUS: 3840 x 2160 FR = 29.999999 fps Duration = 33333334 ; Analog Gain range min 1.000000, max 22.250000; Exposure Range min 13000, max 683709000;

GST_ARGUS: 1920 x 1080 FR = 59.999999 fps Duration = 16666667 ; Analog Gain range min 1.000000, max 22.250000; Exposure Range min 13000, max 683709000;

ARGUS_ERROR: Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute: 903 Frame Rate specified is greater than supported
GST_ARGUS: Running with following settings:
Camera index = 0
Camera mode = 0
Output Stream W = 4032 H = 3040
seconds to Run = 0
Frame Rate = 20.000000
GST_ARGUS: Setup Complete, Starting captures for 0 seconds
GST_ARGUS: Starting repeat capture requests.
CONSUMER: Producer has connected; continuing.
ARGUS_ERROR: Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute: 1139 InvalidState.
GST_ARGUS: Cleaning up
nvbuf_utils: dmabuf_fd -1 mapped entry NOT found
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, threadExecute:694 NvBufSurfaceFromFd Failed.
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, threadFunction:247 (propagating)
ERROR: from element /GstPipeline:pipeline0/GstNvArgusCameraSrc:nvarguscamerasrc0: CANCELLED
Additional debug info:
Argus Error Status
Execution ended after 0:00:00.787472344
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

The driver I used is the following.

Sorry for the bad experience.
Have you tried the lower framerate in 4K res?

I change framerate and result is below.

set to 25fps → NG
set to 21fps → NG
set to 20fps → OK
set to 15fps → OK

If I set under 20fps, I can get video stream.
(But I want to get video with 30fps.)

And I also tried command below.

v4l2-ctl --set-fmt-video=width=4032,height=3040 --set-ctrl bypass_mode=0 --stream-mmap

<<<<<<<<<<<<<<<<<<<<<<<< 19.94fps
<<<<<<<<<<<<<<<<<<<<<<<< 19.94fps
v4l2-ctl --set-fmt-video=width=1920,height=1080 --set-ctrl bypass_mode=0 --stream-mmap

<<<<<<<<<<<<<<<<<<<<<<<< 19.94fps
<<<<<<<<<<<<<<<<<<<<<<<< 19.94fps
<<<<<<<<<<<<<<<<<<<<<<<< 19.94fps

I don’t know why, but 4k and FullHD are same result.

Is these any update about this topic?

My colleague who is in charge of developing the camera driver on the Jetson told me that we have not worked it out. It would be better if you could use the old Jetpack version 4.4.x which works fine.

Thank you for your response.
Do you plan to resolve this issue?
Jetpack 5 should become a standard in the near future, so we hope you will adapt the driver to Jetpack 5.

Is these any update about this topic?

hi @mutsuyuki

For versions above jetpack 5.x, it is really necessary to reduce the frame rate.
This is indeed a problem with Jetpack 5.x, nvidia has imposed a clock limit on versions above Jetpack 5.x, resulting in the need to reduce the frame rate to use the camera. We are currently raising an issue with nvidia about this limitation as well.

Thank you for your information!
I understand the situation.

We would like to follow up information on this issue, so if you know of any web pages of discussions with Nvidia on this topic, could you please let us know?


Your question is a general one, so I added a sticky post under the Jetson module, if there is an update, I will reply below, please be patient.

1 Like