IMX477 12 MP arducam freezing and not recording

  1. Where did you get the camera module(s)?


  1. Model number of the product(s)?
    IMX 477 arducam 12 MP

  2. What hardware/platform were you working on?

  3. Instructions you have followed. (link/manual/etc.)
    Quick start - Arducam Wiki

  4. Problems you were having?
    Seems to be that the problem is in relation to the video encoders

  5. The dmesg log from your hardware?
    I will include my dmesg but while checking there is nothing that stands out

  6. Troubleshooting attempts you’ve made?

Have tried running simple codes for video live stream that works, once adding the enconders it seems that it causes the whole OS to crash and reboots. I have also posted on the nvidias website as well waiting to hear back.
Out of the many things i have tried, there was one thing that bugged me a little bit, it was in relation to picking to camera interface using the python script given on: (24 PINs, I thought that these cameras use 22PIN?)

  1. What help do you need?
    I believe I need help with the enconding part. I have been able to use the same camera on a Jetson nano without any issues.
    Are these cameras suppose to use the CSI 2? cord or the one that is provided should work just as fine?

Any suggestions are much appreciated it, if something isnt clear please let me know, thank you

pages that i have tried:

(MIPI_Camera/Jetson/IMX477/driver at master · ArduCAM/MIPI_Camera · GitHub)
Toubleshoot - Arducam Wiki