IMX462 camera is not recognized

  1. Where did you get the camera module(s)?
    Arducam.com

  2. Model number of the product(s)?
    B0444

  3. What hardware/platform were you working on?
    RPi 4 (bookworm)
    uname -a returns:
    Linux tracker 6.1.0-rpi7-rpi-v8 #1 SMP PREEMPT Debian 1:6.1.63-1+rpt1 (2023-11-24) aarch64 GNU/Linux

  4. Instructions you have followed. (link/manual/etc.)
    Quick Start - Arducam Wiki

  5. Problems you were having?
    libcamera-still --list-cameras' returns No cameras available!`

  6. The dmesg log from your hardware?
    dmesg | grep arducam returns

[    4.807578] arducam-pivariety 10-000c: firmware version: 0x10003

dmesg | grep imx returns no results.

  1. Troubleshooting attempts you’ve made?
    i2cdetect 10 returns a device UU on c0 address.
    also
    Replacing dtoverlay=arducam-pivariety with dtoverlay=imx462 detects this camera as imx290 but it doesn’t work in anyway.
    also
    I bought two cameras and the same result with both of them.

  2. What help do you need?
    How to make this camera work?

Never mind, it started to work after reinstalling RPi with the latest image.

OK, it works with RPi4 but not with CM4. It’s the same problem as described above. I see it on i2c; it can be detected as imx290, but it doesn’t work in any way.

Hi,
First of all, you need to add dtoverlay=arducam-pivariety instead of dtoverlay=imx462 in the config.txt file if you want to access this camera module.
Get back to CM4, as we all know, CM4 has two camera ports. Little heads up that dtoverlay=arducam-pivariety is correct when connecting the camera module to the CAM 1 port and dtoverlay=arducam-pivariety,cam0 is correct when connecting the camera module to the CAM 0 port.

Could you see the video0 mode with the command ls /dev/video0?

At last, have you installed the Arducam custom libcamera on your CM4?
https://docs.arducam.com/Raspberry-Pi-Camera/Pivariety-Camera/Libcamera-User-Guide/#getting-started

Hello, Dion,

Sorry that I didn’t bring details, but yes, I tried all different options, including dtoverlay=arducam-variety,cam0. It works just perfectly with IMX519 (dtoverlay=imx519,cam0), but not with IMX462.
/dev/video0 is not listed.

I would like to know if you used the Same SD card.

No, the OS was installed on CM4 flash. However, in both cases, I used the RPi imager to install the latest 64-bit Raspbian Lite.