Imx298 Pivariety drivers for kernel 5.10.31-v7

Hi,
The linux based image im using has kernel version 5.10.31-v7, and want to connect an imx298 to it, i tried installing the pivariety drivers from github but this version is not supported, if i try to forcefully install it i get the following error when loading the module

modprobe: ERROR: could not insert 'arducam': Exec format error

is there any way i could make the drivers work with this kernel version?

1 Like