Imx230 pivariety install on raspi4

tried to install pivariety IMX230 on raspi4B 8Gig, raspberry OS

CVBS/Composite/TV out (no HDMI display), and raspberry supposed to work headless, but X11 is started and working ok.

installed pivariety apps and dev, but no luck - libcamera apps gets segfault

Linux raspberrypi 5.15.84-v8+ #1613 SMP PREEMPT Thu Jan 5 12:03:08 GMT 2023 aarch64 GNU/Linux
strong text

Made X/EGL preview window
[3:13:45.012439604] [6570] INFO Camera camera_manager.cpp:299 libcamera v0.0.0+4185-8c2b3b43
[3:13:45.030331312] [6574] WARN CameraSensorProperties camera_sensor_properties.cpp:205 No static properties available for ‘arducam-pivariety’
[3:13:45.030413422] [6574] WARN CameraSensorProperties camera_sensor_properties.cpp:207 Please consider updating the camera sensor properties database
[3:13:45.040346325] [6574] ERROR IPAProxy ipa_proxy.cpp:149 Configuration file ‘arducam-pivariety.json’ not found for IPA module ‘raspberrypi’
[3:13:45.379602508] [6574] INFO RPI raspberrypi.cpp:1425 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media4 and ISP device /dev/media2
[3:13:45.380710769] [6570] INFO Camera camera.cpp:1028 configuring streams: (0) 2672x2008-YUV420
[3:13:45.431301311] [6574] INFO RPI raspberrypi.cpp:805 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 2656x2004-SRGGB10_1X10 - Selected unicam format: 2656x2004-pRAA
[3:13:45.502762903] [6579] WARN IPARPI raspberrypi.cpp:810 Could not set AF_MODE - no AF algorithm
Segmentation fault

i tried to find where it gets segfault with gdb:

thread 7 “libcamera-still” received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fe288bec0 (LWP 6657)]
0x0000007fea445c74 in libcamera::ipa::RPi::IPARPi::queueRequest(libcamera::ControlList const&) () from /usr/lib/aarch64-linux-gnu/libcamera/

when i tried just to “patch” that function (make immed return at call that function)- i got preview window working, all ok, but saved files - jpeg and h264 are black/empty
As i understood, cam is working ok on Rasp4B, so seems i something missed
Thanks in advance

reinstalled libcamera v10, seems started to work, but not possible to record video/jpeg max resolution (limit approx 4kx4k still and 3kx1k h264video)

is it possible to capture 5k full res images/video ot RaspberryPI 4B 8gig? VideoRAM set to 256