IMX219 won't reopen after closing pipeline without power cycling camera

  1. Where did you get the camera module(s)?
    Arducam website

  2. Model number of the product(s)?

Arducam 8MP Camarray Hat UC512 rev c

  1. What hardware/platform were you working on?
    Jetpack 4.6 rev3

  2. Instructions you have followed. (link/manual/etc.)
    Camarray – Arducam 8MP IMX219 Synchronized Stereo Camera Bundle Kit - Arducam

  3. Problems you were having?
    When I run the first use camera pipeline command or any pipeline on the camera source it works the first time after closing pipeline and restarting it does not work until I unplug the camera power and plug it back in. I have tried both USB power and GPIO

  4. The dmesg log from your hardware?
    There are no dmesg errors the IMX219 driver is loaded only

  5. Troubleshooting attempts you’ve made?
    reinstall an updated version of Jetpack searching the internet for a solution

  6. What help do you need?
    I would like to know why this is happening and if there is an I2C command that I can use to correct this.

I notice in other peoples console when they close their pipeline it says PowerServiceHwVic::cleanupResources but I do not.