IMX 708 Raspberry pi 5 does not boot if the camera is connected

I recently bought a arducam camera UC-A65 with imx 708 sensor , to connect it to a Raspberry pi 5
i also bought 22 pin to 22pin cable to connect it , i have a 3 A 5V power supply ,

my issu is that when i connect the camera to the raspbery the raspberry does not boot i see a fixed red light , and if i connect the camera while it is running , the raspberry stop immediately.

Are the two devices compatible ? do i have to install a driver ? is the 3A power supply enough ? is the 22 pin cable correct ?

Thank you very much for your help

I doubt that the 22-22 pin cable undermines the boot.
Could you please post the picture of the cable you purchased :question:

thank you for your answer

the cable that i used is not reveversed , i think this caused the problem, now the raspberry does boot but
i followed this tutorial :12MP IMX708 - Arducam Wiki
but the camera is not detected.
thank you very much :smiley:

Hi @Antoine1

Yeah, I want to check if you purchased the correct cable. Could you post its picture here?
Besides, it would be appreciated if you post pictures of the hardware connection.

Can you also post the output of the command below?
cat /boot/firmware/config.txt

here is the images

thank you for your time

I’m having the same problem, I thought it might be a malfunction with the camera or the 22 to 22 pin cable. The Ardu 16mp IMX708 Autofocus pi camera works just fine, same port, but uses a15 to 22 pin to connect to the pi5. But now it has started up with the camera connected to the 0 port, it didn’t like 1,same set up as your pic, but its not detected

Hi guys @Antoine1 @blistertkn
Where did you get such the 22-22 pin white cable? I need to check if it is the correct one to connect this camera module to Pi 5.


i solved my problem , by removing the blue plastic piece of my cable and bending in backward, my problem was that my cable was not reversed so i caused the raspberry to turn off instantly.

then i ran those command and it worked fo me:

sudo apt install -y libcamera-dev libcamera-apps

sudo nano /boot/firmware/config.txt

#For more options and information see


#Some settings may impact device functionality. See link above for details

#Uncomment some or all of these to enable the optional hardware interfaces




#Enable audio (loads snd_bcm2835)


#Automatically load overlays for detected cameras


#Automatically load overlays for detected DSI displays


#Automatically load initramfs files, if found


#Enable DRM VC4 V3D driver



#Don’t have the firmware create an initial video= setting in cmdline.txt.

#Use the kernel’s default instead.


#Run in 64-bit mode


#Disable compensation for displays with overscan


#Run as fast as firmware / board allows



#Enable host mode on the 2711 built-in XHCI USB controller.

#This line should be removed if the legacy DWC2 controller is required

#(e.g. for USB device mode) or if USB support is not required.





Install Arducam Pivariety driver

wget -O

./ -p libcamera

./ -p imx708_b0311_kernel_driver

chmod +x

./ -p imx708_b0311_kernel_driver

Reboot the Raspberry Pi

sudo reboot

#Verify I2C devices

i2cdetect -y 6

Test the camera

libcamera-still -t 10000

i hope it will solve your issues :grinning:

1 Like