ESP32 UNO PSRAM USB drives install in Windows 10 not successful

Hi there

Testing if there is an issue with new Ubuntu 20.04 LTE, decided to give it a go in Win 10. Found the driver to install following URL link:

I followed up the whole procedure (including disabling driver signature) with no success…Has anyone bump into this in Windows 10?

While USB drive under “Device Manager” has “ArduCam USB2.0” driver install, stil there is an error:

Device USB\VID_0000&PID_0002\5&28ff6b09&0&1 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USB\VID_6993&PID_B009\8800819089000127
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Migration Rank: 0xF000FFFFFFFF0030
Present: false
Status: 0xC0000719

Any idea or suggestion highly appreciated.




In fact, if you just need to install the USB driver for ESP32 UNO PSRAM, you should install the driver for this link.

The driver you’re installing is the arducam Shield USB driver, you can check out the description here.

Hello Support,

I am adding a bit more info on here, about what I did to troubleshoot my issue

Win 10 OS does not recognize the board (it does display an unknown device but does not display the driver name/reference under Windows Device Manager) I have tried the following.

  1. Use different USB cables to connect to the PC. No changes at all, and I am sure both USB cables work as I used them to charge my Samsung phone. Also PWR LED lights on the board so there is power delivered to it.

  2. Advice by ArduCam support to download drivers from (read URL link below), but those drivers are from 2006, and when I tried to uninstall/install drivers on that folder using “Win Device Manager”, none of the drivers are suitable for the USB issue. (Device Manager complains about it!!)



Can you download the driver link I gave and directly install the following file?

If there are still problems after installation, please change to another USB port to have a test. If there are still problems, the board is probably broken.