ENOSPC error on IMX477 kit

1.Which seller did you purchase the product(s) from?
UCTRONICS
2.The Model number of the product(s) you have purchased?
Arducam 12MP MINI IMX477 Synchronized Stereo Camera Bundle Kit for Raspberry Pi
3.Which Platform are you using the product(s) on?
Raspberry Pi 4
4.Which instruction are you following?
manual
5.Has your product ever worked properly?
No
6.What problems are you experiencing?

**[email protected]**:**~/MIPI_Camera/RPI $** ./arducamstill -t 0 -m 2

Open camera...

Found sensor imx477 at address 1A

mode: 0, width: 4056, height: 3040, pixelformat: BA81, desc: (null)

mode: 1, width: 2028, height: 1520, pixelformat: BA81, desc: (null)

mode: 2, width: 1920, height: 1080, pixelformat: BA81, desc: (null)

mode: 3, width: 8112, height: 3040, pixelformat: BA81, desc: Used for Arducam synchronized stereo camera HAT, 4056x3040 * 2

index: 0, CID: 0x00980911, desc: V4L2_CID_EXPOSURE, min: 0, max: 65535, default: 1606, current: 1000

mmal: Failed to fix lens shading, use the default mode!

mmal: mmal_vc_port_enable: failed to enable port vc.ril.isp:out:0(I420): ENOSPC

mmal: mmal_port_enable: failed to enable port vc.ril.isp:out:0(I420)(0x1f5ac20) (ENOSPC)

mmal: Failed to enable isp outptu.

mmal: Failed to enable isp output.

mmal: Failed to enable camera

set resolution status = 2

**[email protected]**:**~/MIPI_Camera/RPI $** vcgencmd get_camera

supported=1 detected=1

7.What attempts at troubleshooting have you already made?
Tried Bullseye and Buster. Reset cabling. Trying every Google result I could find.
8.How would you like us to help you?
What am I doing wrong?

You can try Bullseye (01/28 and later) and use libcamera-still.
Then you can refer to this for some simple configuration:

That worked! Thanks so much!