Could not open device node /dev/video0. ToF

I followed the official tutorial and got the following results.

open ***WARNING*** Could not open device node /dev/video0. Please check for permissions.
initialization failed

I can see some similar reports but could not find a solution.
What I did:

  • Auducam-Pivariety Driver update
    sudo apt install arducam-pivariety-sdk-dev
  • check /boot/config.txt
    dtoverlay=arducam-pivariety
  • does the driver exist
    /boot/overlays/arducam-pivariety.dtbo
  • check dmesg
[   10.479222] arducam-pivariety 10-000c: pivariety_read: Reading register 0x103 failed
[   10.479244] arducam-pivariety 10-000c: probe failed

Hi
Please provide hte info of your Raspberry Pi and OS, additionally, you also need to attach the config file here(cat /boot/config.txt)

Thank you for your reply.
I use a Raspberry Pi 4 Model B(4GB RAM)
OS info:

$lsb_release -a

No LSB modules are available.
Distributor ID:	Raspbian
Description:	Raspbian GNU/Linux 11 (bullseye)
Release:	11
Codename:	bullseye

config file:

$cat /boot/config.txt

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
start_x=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
#dtoverlay=vc4-kms-v3d
max_framebuffers=2

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]

[pi4]
dtoverlay=vc4-fkms-v3d
# Run as fast as firmware / board allows
arm_boost=1

[all]
gpu_mem=128
camera_auto_detect=0
dtoverlay=arducam-pivariety

Best Regards.

Hi
You seem not to refer to a correct guidance.

Delete this sentence in the config file and then follow the link below to install relevant dependencies:
https://docs.arducam.com/Raspberry-Pi-Camera/Tof-camera/Getting-Started/#using-the-tof-camera-on-raspberry-pi

1 Like

Hi, I’m having the same issue and was wondering if this ever got resolved. I’ve followed the suggested steps on the ArduCam troubleshooting website and updated the SDK but that isn’t working

I’m having the same issue after attempting to update for the Pi 5

I forgot to post in this thread.
You can easily solve this problem.
It is to follow the README.txt included in the cloned package.
At least it worked in my environment.
I hope it helps someone.
thank you.