Can't get OV5647 Camera to Work with Quad Multi Camera Adapter Board v2.2 on Raspberry Pi 4B


I am working on trying to get the 4 port multi camera board to work with just a single camera at the moment but I can’t seem to make it work in any way. I am using a Raspberry pi 4B 8GB running 64Bit Raspberry Pi OS Bookworm.

I am following this quick start guide:

The one difference I am making is that I am updating my /boot/firmware/config.txt file instead of /boot/config.txt because they appeared to have moved it for Bookworm.

I am running a clean install of Bookworm, I have turned on I2C, I have set camera_auto_detect=0, I added the line
I have the camera connected to the Camera A slot on multi-camera board.

I have checked that the camera works without the multi camera board and that it works with both of the CSI ribbon cables.

It seems that I just can’t get the 4 port driver to load no matter what I do. After rebooting and I run sudo dmesg | grep arducam I get nothing and if I run libcamera-hello --list it says no cameras found, if I do ls /dev/video* there is no /dev/video0.

Any help or advice would be much appreciated.

Additionally, I want to know that once I get this camera working will I be able to change the camera with python over i2c and gpio like I used to do on buster?


@Edward @Dion

Can I provide any more information to get support for this?


try it in the Camera D slot. That’s where Camera 0 was for me.

It would be nice if this were documented …

Hi Zak,
I would like to know how you set camera_auto_detect=0 in the config.txt file. As far as I’m concerned, once I do not add such an entry in the config.txt file, the Raspberry Pi will not detect the setup(ov5647 camera + B012001).
Please post the information below:

  • cat /boot/firmware/config.txt

  • Pictures of hardware connection

  • dmesg | grep ov5647