Cannot open camera.rtn_val = 65281

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?

  3. What hardware/platform were you working on?
    Linux Ubuntu

  4. Instructions you have followed. (link/manual/etc.)
    Followed the installation and build instructions here:
    GitHub - ArduCAM/ArduCAM_USB_Camera_Shield_Cpp_Demo

Tried using the config files from here:
Config/USB3.0_UC-425_Rev.C+UC-628_Rev.B/IMX477 in ArduCAM_USB_Camera_Shield/Config/USB3.0_UC-425_Rev.C+UC-628_Rev.B/IMX477 at master · ArduCAM/ArduCAM_USB_Camera_Shield · GitHub

  1. Problems you were having?
    When I tried to run the ArduCAM_USB_Camera_Shield_Cpp_Demo, terminal shows:
    Cannot open camera.rtn_val = 65281
    Failed to open camera.

  2. Troubleshooting attempts you’ve made?

  • Checked that ArduCAM is connected properly to the USB port and is powered on
  • Verified Device ID and /dev/video Mapping
  • Checked User Permissions
  • Use diagnostic commands like lsusb to ensure the system sees the camera and v4l2-ctl --list-devices to list video capture devices
  1. What help do you need?
    How to solve the error; Failed to open camera.

You referred to the wrong doc. Please check the link below: