Can not get images with IMX298 and v2.2 adapter


Recently I have bought Arducam IMX298 camera and because I am really happy with its performance, I decided to buy another one and connect them with v2.2 multi-camera adapter.
I checked FAQ and I could see that, Arducam support team confirmed that, IMX298 can be used with that. reply(#13887) so I am good here.

Today I wanted to test how 2.2V adapter will work with IMX298 cameras but unfortunately I can not get an image or anything else. I have checked each camera separately and they do work. I have connected 8MP camera to the adapter and it works, but somehow IMX298 do not.

Issue that I have is when I run, I am having error “Can’t find video0 device”

I have checked it on RPi 3B+ and RPi 4B 4GB. On both I have installed Raspbian GNU/Linux 10 (buster)


For the imx298, you should use arducam mipi_camera library.

The demo for Multi-Adapter Board does not support imx298. The

demos are used for imx219 and ov5647.



I forgot to mention that I was using this library but still my Rpi could not see any other i2c address than 0x70. This morning I have did everything one more time from the very beginning and it worked. I have no idea what was wrong but probably it was a mistake on my side inside code.

Unfortunatelly i have a different issue and it looks like it might be a hardware one. From camera connected to Camera C connector, my images have huge amount of noise. I have changed cameras and ribbons to see if one of them was damaged. Did not matter which ribbon or camera I have used, I was always having image with noise. It looks like connector on board might not be soldered “right” but I am not an expert in this matter. If I press the cable gently down at the connector itself, the amount of noise is significantly reduced. I checked a few times if I am connecting cable correctly buy I can not see anything wrong with it…

Is there anything else that I can checked or I should contact your official reseller directly (uctronics) which sold me this adapter?


Image from IMX298 with 2.2 adapter


Hello, which command are you running? It seems the signal is very pool.

Are you testing it on Pi4 platform?




I have modified one of yours examples. To activate for instance camera connected to Camera A connector I am running:

import arducam_mipicamera as arducam
import v4l2 #sudo pip install v4l2
import time, os
import RPi.GPIO as gp

if __name__ == "__main__": try: gp.setwarnings(False) gp.setmode(gp.BOARD)

gp.output(7, 0)
gp.output(11, 0)
gp.output(12, 1)
i2c = “i2cset -y 1 0x70 0x00 0x04”
print(“i2c set!”)

except Exception as e:

And then I am just running example from MIPI_Camera/RPI/opencvGui

I had some time and I have checked adapter on Rpi 3+ B. I did not see any issues there. Image from cameras seemed to be ok. When I got back on RPi4 I got same problems as I described above.

I think last/2 weeks ago we were talking about connecting IMX298 to the Rpi4 when I got some issues with noise. As far as I remember you have slowed down some clocks. Do you think it might be the same issue here?


Most likely, because the Pi4 CSI signal is not as good as Pi3 modeB.


So you are saying that we can not do anything about this and it will not work properly with RPi4?


Have you tested all the modes? As normal, we can reduce the clock and frame rate of the sensor to adapt to PI4.

What I want to ensure is if your sensor is nornal. You can try other modes or test it on Pi3 platform. If your sensor still exist this issue on pi3, maybe your camera is defective and we will arrange to resend one for you.




I had some time this morning to check a few configurations

Rpi3 with v2.2 adapter and 4x imx298

  • modes 0, 1 and 2 from ./capture are working with no problems.
  • mode 3 (full res) capture time out or big (30mb) file with random noise.
  • When trying to capture image in full res with python script NULL pointer access
Rpi3 with imx298
  • modes 0,1,2 and 3 from ./capture are working with no problems
Rpi4 with v2.2 adapter and 4x imx298
  • modes 0,1,2 from ./capture are working with no problems
  • *mode 3 was producing a bit of noise on camC. A, B and D were fine.
Rpi4 with imx298
  • modes 0,1,2 and 3 from ./capture are working with no problems
I swiched cameras in connectors and even swiched cables between them. I could not see any differences so I presume cameras are fine. Especialy when I just connect a camera to Rpi and I am getting normal images in full res. If one of them would be damaged somehow I would not get good results here.

At the end I realised that the only thing I did not change was a ribbon connecting Rpi and adapter. The one I was using was about 15 cm so I changed it into 5cm one. When I started checking cameras I could see improvement for Rpi4.

Rpi4 with v2.2 adapter and 4x imx298 (5cm ribbon RPi<–>adapter)

  • modes 0,1,2,3 from ./capture are working with no problems. I did not see any noise when I was capturing images.
Rpi3 with v2.2 adapter and 4x imx298 (5cm ribbon RPi<-->adapter)
  • No improvements. Still could not get image in mode3(full res)

So that is me. I am quite happy right now I do not see any noise on the images in full res from Rpi4. However I am a bit afraid i got “lucky” today with camera placement and when I turn on Rpi4 tomorrow I will still get noise on images. Anyway, It would be great guys, if we could have an adapter working with 4 IMX298 cameras in full res on Rpi3 also. I am sure plenty of people is still using them (I am an example).


Your test is too detailed, great.

We are planing to update our multi-adapter board to add signal enhancement.